跳转到主内容

Are temperature sensors on Mac Pro Late 2013 serviceable?

My MacPro Late 2013 was starting to run a little warmer to the touch than usual, so I ran TechTool Pro 14 which identified one of two temperature sensors to have failed.

Are the individual sensors serviceable and can anyone recommend a parts source?

If the sensors are bundled within a component assembly, would that component be the fan assembly and would the entire fan assembly need to be replaced, and again, would anyone have a recommendation for a source for the fan assembly?

Thank you.

Update (11/05/2021)

Good morning and thank you, Dan. I am located in the USA, to answer your first question.

In response to your first suggestion, I followed both methods that you mentioned. The onboard diagnostics came back reporting no problems, and TG Pro’s paid version also reported no problems. The screen shot is attached below.

I am at loss as to how and why TechTool Pro 14.1, running under MacOS 12.0.1, and my physical touch would point to a problem, but now two other software applications would contradict that. Any guidance and suggestion from anyone would be greatly appreciated.

Block Image

已回答! 显示答案 我也有这个问题

这是一个好问题吗?

得分 0

评论:

Where are you located Country? So we can aim you to a more local source for parts.

Without a firm idea what the sensor is telling you replacing the fan unit may not be the correct part.

完成的

添加一条评论

1个答案

已选择的解决方案

Yes, No and Maybe!

Without knowing what you are facing we just can’t answer.

I find TG Pro free version gives us a good run down on the sensors, if you get the full version you can get a deeper data on the sensors.

Or you can use the onboard diagnostics to see if a hard error pops. Restart your system and press the D key.

Reference: Mac startup key combinations

In either case we need better data, post a snapshot of the main window of TG Pro making sure all of the sensors are visible so we can see things 在已经存在的问题里加入图片.

这个答案有帮助吗?

得分 1

评论:

@fritzj3 - Well that tells us the fan it OK, But! It might need a good cleaning as over time the dust will build up on the fan blades as well as other parts of your system so it is not effectively cooling.

As far as the snapshot you need to take another one as thew lower sensors got cut off!

Grow the window box so its firs smaller and then stretch the bottom until you get the slider to disappear on the right that way you know you've got all of the sensors within the window space.

完成的

Good morning and thank you, Dan. All the levels registering on the TG Pro screen are in the green. I took the MacPro apart, blew out all the dust and debris out of the interior, put it back together, ran the applications and now there are no problems being displayed in TechTool. Thanks again for you replies and for introducing me to TG Pro - that's a handy bit of software.

完成的

@fritzj3 - Happy to hear all you needed was a dusting!

Don't forget to score the answer and accept it - Thanks!

完成的

添加一条评论

添加你的答案

Peter J Stevens 将永远感激不已
浏览统计数据:

过去的24小时: 0

过去的7天: 3

过去的30天: 12

总计 84