跳转到主内容

Why is my freezer is forsting on the top?

kitchenaid fridge with dual evaporator and the freezer is forsting only at the top of evap coil And the freezer temp is between 20-30F, it should be at 5 to 0F. The fridge temp is ok @38F. My question Is the problem due to low freon or an issue with the freezer heater or defrost thermostat?

回答此问题 我也有这个问题

这是一个好问题吗?

得分 0
2条评论

Sorry and yes , The freezer evap fan is running

I also run all the diagnostic to see if any of the FC&RC thermistors and they pass, I also run the test for the both fan and confirm that they are running and I visually saw that both fan are running .

完成的

the fridge model is kitchenaid KFIS29PBMS01 .

I did notice that the pressure on the low side was going to vacuum and I assumed it is low on Freon and added a little to bring the pressure on the low side back 0 psi. I will check tomorrow if it goes into vacuumed again indicating that there is a leak. You indicated that it is possible the 3 way valve is faulty. if it was the valve, wouldn’t the freezer evap not get any Freon and would not have any frost on it at all ?

FYI, my fridge is working fine and is at the right temp of 36F , and the freezer is now at 32F

完成的

添加一条评论

3个答案

最有帮助的答案

Hi @max999

What is the model number of the refrigerator?

Is the freezer evap fan operating?

Have you checked if the freezer temperature sensor is OK?

If it were low Freon the refrigerator would be warmer as well as there is only the one compressor unit. i.e. one sealed system but with two evap units. Could be a faulty refrigerant valve that is used to direct the refrigerant between the two evap units as required or worst case a partially blocked evap unit but start with the simple things first.

这个答案有帮助吗?

得分 2

11条评论:

the model is kitchenaid KFIS29PBMS01 .

I did notice that the pressure on the low side was going to vacuum and I assumed it is low on Freon and added a little to bring the pressure on the low side back 0 psi. I will check tomorrow if it goes into vacuumed again indicating that there is a leak. You indicated that it is possible the 3 way valve is faulty. if it was the valve, wouldn’t the freezer evap not get any Freon and would not have any frost on it at all ?

FYI, my fridge is working fine and is at the right temp of 36F , and the freezer is now at 32F

完成的

How do I verify that the 3 way valve is faulty?

I know there is a diag. mode in which the 3 way valve Is I placed into home position where Freon is passed to both evap at the same time , would that tell us if the valve is faulty ?

完成的

@max999

The tech sheet doesn't show a test for the 3 way valve but the values of the high/low sealed system pressures are there.

Disconnect the power to the refrigerator for about 10 seconds and then place your finger on top of the 3 way valve and reconnect the power. You should feel the valve move back to the home position i.e. both evaps. That's the only way I know and I'm not sure if it works this way with your model. It restores to the home position after an auto defrost cycle has finished or a power reset. Otherwise you may just have to test the pressures to know if the valve is OK

if there is a loss of pressure due to a leak check for any oily residues on the piping (that you can see), the condenser coils and the compressor unit. There is a special oil mixed in with the refrigerant to help lubricate the compressor and if there is a leak, the refrigerant will escape to the air undetected but the oil "may" leave a trace. Not always but maybe worth a look.

If you suspect a leak the system will need to be evacuated and a refrigeration dye pumped in to hopefully find it. Once found and fixed the system needs to be evacuated again and the correct amount of refrigerant pumped in again and then tested.

完成的

I did see an option on the fridge diagnostics sheets that let you the 3 way valve into home position , and I did feel/hear the valve make a slow 5 tapping sound. Which to mean the valve is working, right ? I purchased R134A leak detector hopefully it can help finding a leak. Btw, after adding a little Freon yesterday evening after noticing the low side pressure going to vacuum, I check this morning morning the pressure is 20psi when the compressor is running and the temperature is at 14F much better than 32F , so is that an indication that the freezer evap is functioning right ? And there is a leak .

also , I hear that it could also be an obstruction somewhere in the freezer system ,I.e cap tube, evap , or 3way vale cap tube , is any of these possible ?

完成的

@max999

I'm no fridge repairer so my knowledge on how to check the various sections of the sealed system is not good.

The sealed system suction and head pressures are shown on the tech sheet (bottom left corner) and I think the in and out temperatures for both evaporators as well, but how you would accurately measure the temps there don't know

Perhaps @brandon_k may be able to help ;-)

完成的

显示更多的6条评论

添加一条评论

what is most likely to cause this issue is a leaking seal. It may just be the the freezer door is not completely closing because something is holding it ever so slightly open. You may not even be able to detect that. My sister had that problem with hers. I had to remove the seal to realize the door was hitting a bottom drawer. Just removing the plastic fascia solved the problem. Never figured out why it was sticking out so slightly.

这个答案有帮助吗?

得分 0

1条评论:

While a bad seal IS a problem.... one of the key signs is an iced up evaporator. Here it is only frosting at the top of the evap, and still not maintaining temp. If the door seals were the issue the whole evap would have frozen up, blocking airflow. Bad door seals are a surefire way to get moisture infiltration.

完成的

添加一条评论

I have the same problem and from the long term research I ve done on this dual evaporator system a bs design. The techs seem to be focusing on a defective 3 way refrigerant valve getting stuck in the wrong position.Tap on valve to see if it clicks to start compressor. If it starts replace the valve assembly.

这个答案有帮助吗?

得分 0
添加一条评论

添加你的答案

Max 将永远感激不已
浏览统计数据:

过去 24 小时: 0

过去 7 天: 1

过去 30 天: 6

总计 109