Switch powers up on Nintendo logo then shuts off?

I replaced my Switch battery and in doing so, I seem to have upset something, because it doesn't work anymore. I replaced the thermal paste while I was there, removing the heatsink as well, but left the bottom piece connected to the motherboard/processor alone.

When I press the power button, the Switch powers on and displays the Nintendo logo, but then shuts back off 2 seconds later. I've tried holding down the power button for 30seconds and releasing, then pressing power again, but I get the same result.

It doesn't seem to recognize the wall charger. I've also plugged it into the dock, the dock power light flashes for a split second before going back off.

Unfortunately, and I don't know if this is cause for concern, but when I reassembled the Switch I had accidentally installed the SD card reader under the metal shield instead of on top, and I had almost screwed it all the way down before realizing I had it on the wrong way. The motherboard appears to be okay, but I have no way of testing it.

Ugh I'm so bummed. My switch is 4 years old and was hoping to breathe new life into it. Now I am unsure if Nintendo will operate on my Switch after having just replaced the battery myself. The battery seems to be working though.

I’ve disassembled the Switch and tried again, disconnecting the power and pressing the power button for 10 seconds to discharge the motherboard, but I still have the same problems. The game cartridge and SD card are also removed. Please advise, what should I do?

回答此问题 我也有这个问题

这是一个好问题吗?

得分 0
添加一条评论