2.2, 2.4, 2.5, or 2.6 GHz Core 2 Duo processor

962 个问题 查看全部

MacBook Pro Will Not Power On!

Yesterday, a friend at work and I were talking about his MacBook pro. He inquired about a few things including Windows 7 on it. I said I'd be happy to set up BootCamp for him. While at it, he said that he had purchased a Lion USB drive and asked if he should upgrade. I've done thousands of Windows installs and a few OSX ones so I said I'd do it for him.

Today, I received his MacBook Pro (Late 2008) 2.4 Intel Dual Core CPU / 2GB RAM, his software, and the Lion USB key. I booted into OSX and copied his "profile" over the network to a SMB share. I tried upgrading directly with Lion, but it wouldn't let me as I found out it had to be upgraded from 10.6.X - not 10.5.X. Therefore, I decided to do a clean install.

I booted to the 10.7 Lion USB drive and went into Disk Utility where I erased the hard drive. I only erased it - didn't repartition or change drive's format. Before proceeding, I thought I'd be nice and go one step further for this guy and install new RAM into his computer. It was 2x 2GB SO-DIMM 667MHZ RAM which I read would work with it and double his RAM to bring it to 4gb. I installed it.

The Problem

I turned the computer back on with the Lion USB in and only got a white screen. The cursor appeared, but nothing else. I thought that since there wasn't an OS on the HDD, that it would default to the next boot device as PCs do, but it didn't. I turned it off, then back on again - except - it didn't come back on!

So that's where I am. I have a friend's computer which won't turn on.

Note: The battery is bad I've been told and will always show only 1 light of power. The power cord is good, though.

Here's what I've tried so far:

- Removed the battery / power cord for 5 minutes

- Tried with just the power inserted (Get green light on power cord)

- Reinserted original RAM (actually did that first and it has stayed that way during all T/S)

- Swapped RAM into other's socket

- Removed battery & Power - held the power button down for 10 seconds - reinserted and tried to power back on

- Got Stressed!!!

Any suggestions would be great - Thanks!!!

已回答! View the answer 我也有这个问题


按维修分数 1

所有超过US$100或包含 Pro Tech工具包的订单免费送货!




I've only been able to install to 10.6.8 and had to upgrade even 10.6.6. I have yet to do a clean straight install on 10.7. So you may have to do it from a 10.6.8 installation.


按维修分数 4


Thanks - but the issue is that I can't even get it to power on let alone display anything on the screen or boot to an OS.

My experience has shown that this machine will not boot till the battery has about a 15% charge. If it won't charge to that, replace it.



Ben Kellermann 将永远感激不已

过去的24小时: 0

过去的7天: 0

过去的30天: 1

总计 929