跳转到主内容

A compilation of guides for counter-top and handheld blender repair.

282 个问题 查看全部

My blender's motor is not activating, but my lights are on.

I have a decent but off-brand blender by Anthter, which costs a pretty penny, and I have already received a replacement for my faulty device. However I don't really want to toss my device that's faulty, so I was hoping I could fix it and use it eventually.

This occured on my 3rd use of the blender ever, trying to crush up some grain in it. I'm pretty certain I must have overheated it or busted something because in the middle of blending a bunch of grain, it stopped working suddenly.

The lights go on when plugged in, and everything acts normal, but the blender will not activate the motor. In fact there is no sound at all. The safety button to make sure the container is in is definitely pressed in. It's got to do something with something else. It's been like this for about a month, so it's definitely cooled down.

Any help at all would be really appreciated!.

回答此问题 我也有这个问题

这是一个好问题吗?

得分 0
添加一条评论

1个答案

well if you've already received a replacement, I say grab some tools. With it unplugged, open it up. Check the motor. Check all wire connections to make sure they're good. One could be burnt. Then, check the motor. You'll want to do a continuity check across the windings, and then from the windings to ground (like the shell of the motor) and let us know the results. Motor might be toast. If you don't have continuity across the windings, or if you DO have continuity to ground, motor is bad. Can probably order a new motor.

这个答案有帮助吗?

得分 0
添加一条评论

添加你的答案

Joseph Gerard 将永远感激不已
浏览统计数据:

过去的24小时: 0

过去的7天: 0

过去的30天: 1

总计 13