2009 Mac mini shutting down during boot, just after chime

My early-2009 Mac mini works normally *until* you have to restart it (which I have to do occasionally as it’s a dual-boot system).

When you restart it, about 7 times out of 10 it will shut down just a few seconds after the startup chime. It doesn’t show the “NO” symbol, or anything else - the startup chime sounds, the grey boot screen appears, and then it shuts down like someone’s pulled the power cable out.

If you keep trying, eventually it will boot normally and then everything will be fine - it will run happily for days, until I need to boot into a different OS and then the problem reoccurs.

It’s definitely NOT the hard drive (actually an SSD) - I’ve replaced it with a brand-new one with a fresh OS install, and the same thing is happening.

It’s also not the PRAM or SMC - I’ve reset both (and replaced the PRAM battery), with no effect.

Could it possibly be the fan? After 12 years of being on almost 24/7 (generally with just a few weeks off each year), I’m wondering if the fan bearing is starting to go bad, so isn’t always spinning up as well as it should and the machine is able to detect this and immediately shut down?

回答此问题 我也有这个问题

这是一个好问题吗?

得分 0

评论:

Let's try running the onboard diagnostics to see if an error pops. Restart your system and press the D key. Let us know if you get any error codes.

完成的

@danj Being a 2009 it doesn't have the diagnostics built in, you're supposed to run them from the original install DVD - which I don't have any more. I think I'm onto a lead for a way of downloading them and putting them onto a bootable USB stick though, so we'll see if that works.

完成的

@gdubai - If you've been maintaining your system with the OS-X El Capitan (10.11.x) I think the firmware upgrade now offers it.

Give it a try using a USB keyboard. Mac startup key combinations

完成的

添加一条评论