跳转到主内容

The ASUS ZenPad 3S 10 is a 9.7-inch tablet in the ZenPad line released by ASUS in October 2015. Model: P027.

21 个问题 查看全部

Screen black but illuminated

Hi

I broke the screen of my asus z500m tablet but it worked. I still could use it. After a day or so the screen was not working. It was black but illuminated. I unplugged and plugged it again the battery but nothing improved. If I plug it to AC sometimes turn on the screen illuminated but without image and blink. The motherboard it feels hot. I don’t know if it’s problem of the charging port or motherboard. Is it possible to fix it?

回答此问题 我也有这个问题

这是一个好问题吗?

得分 0
添加一条评论

5个答案

最有帮助的答案

hokshy sounds like your screen damage is causing this. It may have worked somewhat in the beginning but the damage is extending. It is probably shortening out and causing the rest of your tablet to heat up. It is illuminated since the backlight (separate circuitry) still comes on. You cannot properly diagnose this until you replace the screen. Use something like this video to work on it. Since there are no guides for this repair on iFixit I would also suggest that you create one for the rest of us. https://www.ifixit.com/Guide/new

这个答案有帮助吗?

得分 1

2条评论:

Sorry I didn’t mention it. I have replaced the screen but happens the same.

完成的

hokshy that makes it an issue with the circuit board. Since you already changed the screen and your backlight works, this would be the video circuity. Check the connector to make sure that everything is seated properly. Check for bend or broken pins.

完成的

添加一条评论

I have the same problem, the device fell and the screen got cracked. First the touchscreen only didn’t work but the screen itself worked. Now after screen replacement both the new and old screen light up but there’s no picture. I can hear android loading up though. I didn’t even touch the motherboard. Could it be the flex cable connecting the display? Tablet is z500kl

这个答案有帮助吗?

得分 0
添加一条评论

In my case, someone said me that the usb-type-c port didn’t work and some optoelectric components either. If someone knows how to find exactly the opto and how replace it, I would try to do it but it’s very difficult for me to do that in this moment. I’m thinking to throw it away to recycle but the screen is new and works perfectly. It’s a pity that there are no more info to repair this things.

I don’ t know anything about the z500kl but it could be the same problem especially, if you don’t see charging icon when plug in to AC. But in my case I can’t hear anything either.

这个答案有帮助吗?

得分 0
添加一条评论

It sounds like a motherboard problem. I had a very similar problem and changing the motherboard solved the issue.

这个答案有帮助吗?

得分 0
添加一条评论

I fixed my asus 10 by carefully removing the plastic back and I gently flexed it. It may be a temporary fix, , I also smelled the back to see if any burnt components were present. I made sure the ribbon plug were on snug and it is working now.

这个答案有帮助吗?

得分 0
添加一条评论

添加你的答案

hokshy 将永远感激不已
浏览统计数据:

过去 24 小时: 1

过去 7 天: 3

过去 30 天: 32

总计 691