My surface pen is paired but does not write on my surface

My surface pen is connected , the top button works but it does not write. However, when i tested the pen with my friend’s surface, it worked properly.

I also tested that my touch screen worked, i.e i could open apps by touching the icons with my fingers, writing in onenote, pinching and zooming with 2 fingers…

I suspect the issue could be that some drivers are missing but i’m not sure which one. What are all the drivers related to the surface pen ?

回答此问题 我也有这个问题

这是一个好问题吗?

按维修分数 0

评论:

Uninstall the pen in Windows -> Device Manager

Make sure all Windows System updates have been done

Shut down your computer.

Personally I prefer doing a hard shutdown using the following sequence:

The following command will compleatly shut down your computer in Windows:

Right click Start icon and select Command Prompt

Type or copy/paste the following in that window:

C:\Windows\System32\shutdown.exe /s /t 0

Then reboot the computer.

Pair your device and Windows should re-install all device drivers needed for the unit.

添加一条评论