Why is MacBook Pro stuck in Apple logo with a spinning wheel?

I was updating the software for my MacBook Pro, and suddenly I got and important call and closed the lid and now my machine won't boot. It's stuck on the Apple logo and a spinning wheel. Please help.

已回答! 显示答案 我也有这个问题


得分 5


I have a macbook pro early 2008 I am using now 10.6.8...

I am trying to install 10.9 using a bootable USB, but I am stuck for hours staring at the spinning wheel. Any suggestions on what to do? I am now using 10.6.8 at the moment. Help me please.


I followed Mayer's suggestion below and it worked. I think my obsolete 2008 MaC per Apple is on its last hardware legs, but it is running again. Thank you Mayer! You have my vote!


Thank you very much. I look forward to your next share https://word-unscrambler.io





Try starting up in Safe Mode, then try finishing your updates. To start in safe mode hold down the Shift key when starting up. Were you doing a system upgrade or software updates? If you've installed Lion, start up holding down the "R" key.


得分 9


hi thanks for your time i already did that but i will load and remain in the same stage. i tried booting from cd by pressing c at start up but still hang at the same screen i am using Mac OS X Snow Leopard Upgrade DVD. could this be a problem with the cd? i cannot find the original disc that came with the laptop. anything else i need to do?


Of course your Disk Repair utility is on that original disk. Some of the very early 10.6 upgrade disk were actually upgrade disks, while some were full install. I'm concerned that you can't load from your DVD. Unplug everything and hold down the power button for 10 seconds. Next lets zap the PRAM. Restart holding down the Command, Option and P & R keys. Hold it till it tones three times then let go and see if it boots. Also do you have another Intel Mac of any type?


i solved the problem with an original Mac OS X 10.6.3 for MacBook Pro 13INCH. i did full system restore. if you have data on your HDD remove the HDD and connect to usb on another Mac and backup your data. then do a full system restore by pressing C at startup Before the CHIM sound. Good Luck.


Mayer I tried your last comment and it didnt work ziggyb629


@ Jacm Baker - You may have a different problem here. How about creating your own question with all of your details.




Solution that worked for me. First, this is for the late 2011 Mac

Book Pro.

After doing a software update for Office 2011, my mac got stuck on the start up with the logo and spinning wheel.

Power down you macbook. Now press and hold the "Option" key and the Power button at the same time until a screen comes up with two icons: one that says "macintosh HD" and another that says "recovery HD"

Press on Recovery HD. Then when the utilities screen comes up, click on "reinstall Mac OS X"

You will see a progress bar that says it will take about 16 hours.

Just leave our monitor in the open position.

The next morning, I clicked the trackpad and my screen was black. Then I clicked on F2 to increase the brightness and there was my desktop!

I powered it down again just to make sure it would reboot correctly and it did.

Hope this helps!


得分 1


Yeah. This solution worked perfectly! I got am an estimated time of 1 hour and 25 minutes for recovery. I will update if when it recovers! Thanks! This is it!


Any chance of lost data if I have no back up externals


If your drive is in trouble you may want to find a friend with a Mac so you can connect yours in Target Mode and then salvage your important files. Afterwards run Disk Utility from your friends system to see if you can fix it that way. If you have a bootable external drive you can try booting up with it.

Its iffy just trying to re-install the OS as you may end up with more of a mess.


It said "cannot installed on the recovery HD"


It takes me back to the apple logo with the spinning wheel of death when i Press the recovery and Also the macintosh hd logo





I really have to reuse this post because I have the same issue and perhaps found another way to solve it. But I want to understand why this way may work.

1.) Stuck in bootscreen - loading indicator spinning forever.

2.) Tried every hint of this post. Nothing worked.

3.) Tried to boot the Mac with a bootable backup (via SuperDuper) of another Mac on an external HDD - worked just fine.

4.) Did a backup of the "broken" Mac on external HDD via SuperDuper.

5.) Tried to boot it on another Mac. Worked just fine!!!

6.) Tried to boot it on the "broken" Mac. Worked just fine!!!

So why does the exact copy of the system boot from external HDD and not from the internal one? I think there might still be issues with the permissions. When I tried to fix them on the "broken" Mac, there were several error messages, telling me some permissions were not able to be fixed.

My idea now: Format the HDD of the "broken" Mac. Clone the backup of it that I put on the external HDD back to the HDD in the "broken" Mac via SuperDuper. Perhaps it repeats its magic and everythin will work fine again.

Or you know by reading my descriptions, what this magic is and I can perform it via terminal or disk tool without having to erase my system?

I'm looking forward to your reply and thank you a lot in advance for your help.



P.S.: MacBook Pro Mid 2009, 2,66 Core 2 Duo, 4 GB RAM, 320 GB HDD, OS X 10.9.2


得分 1


Nothing worked. I assume, the HDD controller is broken.




MacBook Air - El Capitan 10.11.1

Exactly the same for me : color wheel at startup…

Boot on external HD under Yosemite, backup with SuperDuper in a .dmg, format "broken" HD and restore from the image via SuperDuper.

Restart OK !!


Thank you for your help





When your Macbook hangs at startup.It could indicate a hardware or software related issue.

Hard ware issue can be detected by running disk utility.If your hard drive is falling, You should immoderately attempt to back up all the information on your computer on prevent losing valuable business data such as contacts ,Email ,Projects and invoices .Then take your Macbook to an Apple store or repair shop to install a new hard drive .If the problem software related ,you can get your Macbook up and running again with a few troubleshooting steps .

> Safe Boot

> Disk Utility

> Single-User Mode

> Recovery Console

visit '''FIX-Why is MacBook Pro stuck in Apple logo'''

=> Use disk utility to check the status of your hard disk and make sure that you do not have a failing hard drive.

Shutdown your computer ; restart and then hold down the "Command -R" keys untill you see the OS X Recovery utility screen .

Select the "Disk Utility" option and select the "First Aid" tab


得分 1

Any retail install DVD that has a later operating system than the one your computer came with will work the same way your original install disk does. If you can buy/beg/borrow/steal a retail install disk that came out after your computer, you can:

  1. boot from it
  2. run Disk Utility to repair your hard drive and permissions
  3. (if necessary) do a clean install of the OS

Check EveryMac for the list of compatible operating systems. Search for your particular generation of MBP, then scroll down to the bottom of the window for "Pre-Installed MacOS" and "Maximum MacOS".

NOTE: Although you can't use an installer disk for another computer model to install an OS, you can use it to run repair utilities. For example, a 10.5.4 DVD marked for an early 2008 MBP will not install 10.5.4 on an early 2008 iMac. But you can use the MBP disk to boot the iMac and run Disk Utility or Password Reset.


得分 0

I have a MacBook Pro 13'' with OS X 10.6.3, I was upgrading to Lion and it was getting stuck in Apple logo with the loading icon.

I pressed cmd + opt + P + R and let it restart three times and worked


得分 0

I have a macbook pro 15" for approximately two years old without a single startup issue and very few crashes. After a recent upgrade to Lion I have been having intermittent problems with the spinning colored wheel at start up or startup taking forever and frequent full system crashes. Only way to fix these is holding down the power off button and restarting. I have lost count how many times I have had to do this.

As I had upgraded from leopard I suspected it was due to legacy system settings or simply overloaded with startup items. After backing up all my data, I used the Lion recovery procedures (hold down Command + R at startup) to erase the hard drive and reinstall lion over the internet. You would think this would fix the issue as the only software installed on the machine was a clean install of lion.

This improved the speed and reliabilty a great deal, however it didn't get rid of the spinning wheel issue.

Reading about other similar problems with Lion someone recomended repairing disk permissions using the Disk Utility app (incorrect records of software files installed). Surprising I had any permissions errors given I had erased the drive but there were many - this did reduce the frequency of the startup problems.

The next suggestion was to clean up the system caches. I used an app to do this but you can delete them directly (suggest you google how).

This appears to have fixed the issue. But has not been very long since I did this. Fingers crossed.


得分 0

It could always be the logic board. I've had to replace mine twice (once every two years). First time covered by apple care. 2nd time $330 at Apple store.

It's a known issue with the last silver keyboard MBP model. There's a class action lawsuit as it appears apple put these machines out with a known issue with that particular logic board and most owners of that machine have experienced the issue.


得分 0


I was checking persistently this online diary and I'm awed! important information uncommonly the last part I take care of such information a lot. I am energetic to find this post extraordinarily accommodating for me, as it contains part of... You have a conventional point here! I have bookmarked it and I am envisioning examining new articles.










Yes, that is correct. The Class Action lawsuit is pending in Federal District Court.

The lawsuit alleges that Apple knowingly sold defective Logic boards. Most of the problems are due to a manufacturing defect (as these models were made in China). Lately, Apple has had a slew of defective products to include Iphone Antennas that didn't work, power cords that fray and spark, Nvidia graphic cards that don't work, etc. So, its par for the course.

There is cost savings with China manufacture, however the quality decreases and is not equivalent to electronics made in Singapore, Japan, Taiwan, or the United States. Hence, Apple's move to shift some production back to the United States.


得分 0

I had same problem 5 minutes ago. What helped me is...

1) Use Option Left Key and power button to run MBP

2) When you see two drives "Macinotsh HD" and "Recovery HD" - something like this pick Recovery Disk.

3) After picking your desired language press next.

4) You will see list of possibilities like Online help, Time machine recovery , reinstall, but you pick Hard Drive Tools.

5) Select your major drive and pick "Verify Disk Permissions" after that process. If found errors

pick "Repair Disk Permissions".

5a) You may also want to check your hard drive sectors, just pick "Verify Disk"

6) Restart MBP.

Screen of HD Tools: http://cdn.techgyd.com/macosx-disk-utili...


Actually It was my fault becasue I work on XAMP and set Sudo Level permissions to some folders.

Once I've done it something went wrong and after restart I get spinning wheel and apple logo.

I also tried Soft Boot, shift+option+command and R+P keys, nothing worked. This up above does.

It may not be permission issues setted via Terminal but as I said in my case worked perfectly.

Best regards



得分 0

I have a macpro still with tiger on it for some reason shut screen trash was not finished emptying, when I restarted got apple love spinning globe nonstop,and for some reason I changed the dhcp or whatever and have tried different ways all I keep getting is globe spinning nonstop or lock with bar under tried passwords still globe or lock,help tried safe mode didn't seem to work should I be online to do this should I be plugged in? Tried so many things still stuck. Help please


得分 0

I just had this issue on my early 2011 MBP 17 OSX 1068, after using CCC(Carbon Copy Cloner) to restore from a Backup(my original HD get damaged).

What I am doing now is:

- boot from original Apple Install DVD pressing "C" down on boot

- after choosing a Language, at the top menu, I use Utilities/Disk Utilities/ format the new HD as OSX journaled

- install OSX 1068 and do all the updates

- use CCC to recover files from Backup HD


得分 0


Julius Nfor 将永远感激不已

过去的24小时: 10

过去的7天: 100

过去的30天: 423

总计 267,616