配件 & 工具

Introduced in March 2009, The Mac Pro (Early 2009) introduced Intel's Nehalem architecture to Apple's professional desktop line and introduced a subtle redesigned interior that remained through the 2010 and 2012 CPU updates.

96 个问题 查看全部

Mystery CPU Diagnostic Light

I recently upgraded my 5,1 flashed 2009 Mac Pro to dual 6-core X5680s as well as 128 GB of RAM. Since this upgrade I’ve encountered a few issues that oddly don’t seem to be causing any problems following boot up.

Currently I’m dealing with a CPU diagnostic light that won’t go away no matter what I’ve tried. The strange thing is that when I power on the computer, the light shuts off and the computer proceeds to boot completely fine. I don’t see the OS throwing up any errors, it recognizes both CPUs are in place.

I’ve moved RAM cards around, pulled the heatsink and reapplied thermal paste, and attempted an SMC reset but so far nothing has worked. Any help in figuring this out will be greatly appreciated.

Edit: Both CPU LEDs are actually illuminated, I just didn’t notice the second one since it was obscured by the heatsink.

Block Image

已回答! View the answer 我也有这个问题


得分 0

LCD iPhone 屏幕维修套装



LCD iPhone 屏幕维修套装





Alright final update for this “problem”, as this thing just continues to confuse me. I finished getting this rig ready for sale with the last round of upgrades and set it aside for photos. As I was intending on parting ways with this thing with the diagnostic lights still on, I photoed the thing running hooked up to a display to show the machine functions, except this was what surprised me: the diagnostic lights are gone. They flash briefly on startup and shutdown but they no longer stay on like they used to. I have absolutely no idea what caused this as the only thing I did was install a GPU and Mojave, let the thing sit without power for a day, then plugged it back in and viola! I’ve power cycled this thing several times since just to see if it decides to jack with me some more but so far it seems happy.

Hopefully this escapade helps anybody who runs into a similar fluke, though I’m still unsure what started it in the first place. Cheers.


得分 1

I would suggest booting into verbose mode to see if the boot process spits out any recognizable errors that you can search up. When it comes to any seemingly hopeless Mac issue, I go there. The only thing that comes to mind is maybe an EFI-related problem.

Coming straight from the Mac Pro 2009 Technician Guide, the description of the CPU Diag LEDs states:

The 8-core and quad-core riser boards include a diagnostic LED for each processor that you

can use in troubleshooting processor issues. The following illustrations show the location of

each LED and its associated processor. These error LEDs are normally off. A red illuminated LED

indicates the associated processor may be missing or in overtemp state (PROCHOT).

(Page 34 of the Tech Guide posted here)

However, if you wanted to see if its truly a CPU related issue, it suggests:

Determine if the error LED follows the processor heatsink; verify the heatsink is physically

undamaged and properly connected to the processor board, check that adequate thermal

grease is applied, and verify the fan is operating. For 8 core riser boards only: determine if the

error LED follows the processor by swapping processor A and processor B locations.

So, swap the CPUs into each others slots, see if the light changes to the opposite LED. If so, I’d guess it’s the CPU.

If all else fails, I’d say maybe something went wrong during the flashing process and the EFI is damaged, in which case you’d have to retry that entire process. But, rule out everything else first. Read through the technician guide to see if you find anything else that could be an issue.

Let me know if this helps,



得分 0


Sorry, both CPU LEDs are actually lit. Not sure how much this affects the process.

Not entirely sure what I'm looking for in verbose since the machine blazes through the boot up process before taking me to the desktop like nothing happened. This is what puzzles me is I have zero indication there's a problem until the machine is off.

Either way, I swapped both CPUs and did an SMC reset to see if that changed anything but both lights persisted prior to startup and after shutdown. Again, the computer booted just fine and recognized both CPUs.

I even pulled both the X5680s and popped in the old Nehalem E5520s that I replaced, and the lights still persist. The thing still boots up fine as well.

This all leads me to believe it may be an EFI issue in regards to the 4,1 -> 5,1 flash. As I am still fairly inexperienced in regards to troubleshooting these machines(this is only my second 2009 build, first one went smooth as butter) whatever it will take to fix this I will need a bit of guidance on.


Did not see that both LEDs were lit, my apologies. I would try the flash again then. That or ignore it, unless you're trying to sell the machine. Don't want to sell a potentially ticking time-bomb to someone.


@alexrobinson True that, and I don't plan on holding onto this thing after I'm done with it so I'd rather not have to explain to a potential buyer why it's got diagnostic lights on both CPUs despite appearing to work.

That said, I feel like I have a grasp on how to reflash it: put the hardware back to stock and use the roll back function on the firmware tool? Then redo the whole thing?

Worst case scenario I'll just take the hit on it and try my luck with another machine. Can't really expect doing this kind of extensive upgrading on a decade old rig to be without some hiccups. Might have gotten a bit spoiled after how well my first build went. :P




YALE70 将永远感激不已

过去的24小时: 1

过去的7天: 13

过去的30天: 99

总计 453