跳转到主内容

Model A1419 / EMC 2806 / Late 2014 or Mid 2015. 3.3 or 3.5 GHz Core i5 or 4.0 GHz Core i7 (ID iMac15,1); EMC 2834 late 2015 / 3.3 or 3.5 GHz Core i5 or 4.0 GHz Core i7 (iMac17,1) All with Retina 5K displays

277 个问题 查看全部

Random flickering screen - does seem to 'fix' on reboot

I've done some research and it seems more people have the same issue.

This video ain't mine (so far my issue ain't that bad only similar):

https://www.youtube.com/watch?v=AWW9bt1T...

It can go days with no issues and then it happens usually starts when I'm scrolling through my mails on Outlook and when it does start even checking my apps on the dock (Dock's amplifier effect) triggers it as well.

Then I reboot and all is well for days…

What is that? Could it be faulty cable or a software issue maybe a firmware thing or even something with Mojave's Metal…?

Oh and I've seen the copy/paste reply sent to others online saying ‘replace display here's the guide’. That's not what I'm after.

First those displays are almost as expensive as the iMac itself but also other than this random flickering it works fine there has to be an answer other than the usual Apple motto ‘pay heaps of cash to replace or a truckload of money to buy brand new’.

This is iFixit, doesn't anyone knows how to fix this…?

Update (07/14/2019)

After reading on MS forums many more people having issues with Outlook flickering screen on Mojave I downgraded mine to a previous version.

Actually tried as far back as 2011 but that wouldn't read my files and 2016 wouldn't even run on Mojave (all other Office 2016 apps would though) so I reinstalled Office 2019 and left it un-updated.

Current Outlook version is 16.19 will see if it still happens or not and keep this here updated.

Also gonna do the ‘heat management’ thing mentioned below anyway. Just gonna take a bit longer so the 'downgrading test’ still holds value I think…

Update (10/04/2019)

An update on the issue: running a slightly outdated version of Outlook seems to have ‘fixed’ it. Haven't had ANY issues since so yeah it's either an Outlook problem or dark mode compatibility (in my case dark mode vs Outlook).

Either way it ain't hardware which is good news :)

What is not good news is the fact that the screen does have backlight bleeding which to be fair mine is hardly visible but once you see it you can't unsee it. :(

回答此问题 我也有这个问题

这是一个好问题吗?

按维修分数 0

评论:

Ok so this just happened after about a month without issues: was scrolling Outlook and started to flicker so I closed the app and started to scroll my files on Finder.

On Finder nothing happened but when un-hiding the Dock and magnifying its icons it was flickering but much less than with Outlook.

So I opened Outlook again and scrolled once more. This time before flickering I got beach ball for an instant and then the flickering resumed - that was really odd!

So I rebooted and now it's fine again… What the heck…?

Any solutions for this? I have a similar issue with my iMac 27" 5k mid-2015.

So far what I’ve done is to roll back to a older version of Outlook and haven’t had issues anymore.

Not a fix but a workaround..?

I’m still gonna replace the display though. Noticed it has backlight bleed - you can see it in the edges or corners when looking into a totally black screen.

Those models seems plagued with display issues though so I don’t know to what point is it worth that much hassle...

添加一条评论

5个回答

最有帮助的答案

Sadly you’re not going to like my answer either ;-{ Your display assembly has failed, you need a new display.

OK I get it… What!! What could be going on to do this!! WHY, WHY!!!

OK, heres the dope!

Your display has a logic board on it which is called a T-CON it drives the LCD panel X & Y lines that energies the given pixels row by row, column by column! So when it messes up you get the fireworks you saw on in the video. Its also possible to damage it if you don’t use the proper tools taking the display off.

Block Image

Review the iFixit teardown here 配备英特尔处理器 27英寸5K视网膜显示屏的iMac拆解 Jump down to Step 6 for more details

这个答案有帮助吗?

按维修分数 3

评论:

But why is it that it is fine for days and suddenly start flickering (like I said usually scrolling Outlook emails) then it's fine again after reboot? And it will keep going for days, weeks maybe, only to start again out of nowhere…

Could it be one of those chips highlighted on the T-CON board (step 6) is faulty…?

It could be a bad chip, capacitor or solder joint. The alteration of the pixels as you scroll the image or heat could set it off.

This is not really a serviceable part as the display ribbon cables are welded to it so you can't take it off to work on it. Trying to solder or even applying a heat gun will damage the display under it.

I was also thinking heat could be the issue specially since those units don't have vents on top like older models…

Well if replacement is the only other option then I don't really have much to lose so I'll try to glue some copper shims on those chips and see what happens…

The heat would be from the LED backlights which is just behind the board. I don't see adding any copper will change things don't forget the metal cover is just above I could see using some thermal pads filling the gap between the chip and the cover (just snug ,not pressing) as a better solution if that was the issue.

As for the systems cooling design it uses a pull fan unlike the older models which exhausts out the back which is more powerful than the chimney effect the older models used (more CFM's).

Yeah I've been encoding videos the past 2 days and nothing… will switch off dark mode and see what happens then…

The thing with getting something between the board and cover is I don't want anything pressing anything: if there is room for shims I'll do it otherwise I won't (ones I have are 15mm square by 0,3mm). I do have thermal pads as well and that could be an alternative thanks :)

显示更多的4条评论

添加一条评论

Mine does the same thing when I scroll through my Outlook. Reboot and it’s fine

这个答案有帮助吗?

按维修分数 1

评论:

Only Outlook as well? Weird…

添加一条评论

This doesn’t look like a screen issue, we just had one of these Macs in with the same issue, changed the screen and the same problem. This looks like an outlook/dark mode issue

这个答案有帮助吗?

按维修分数 1
添加一条评论

Ive got 20 of these 27” iMacs, each with a 27” secondary Apple display. Just about every single one has exhibited this problem. Reboot fixes it. Can start again in a day, week, or month, totally random. I certainly don’t think this is hardware related.

这个答案有帮助吗?

按维修分数 1

评论:

Yes I also have the same experience but its been a month already without experiencing it. It really seems like it's software related (i.e. Drivers, compatibility, etc)

添加一条评论

I have the same issue with my iMac when rendering or working using Final Cut Pro X. It happened twice already. I didn’t have this problem before updating to macOS Mojave 10.14.6. This is a bummer.

iMac (Retina 5K, 27-inch, Late 2015)

3.3 GHz Intel Core i5

AMD Radeon R9 M395 2 GB

I have already reported this problem to their e-mail feedback system and I haven’t got any reply yet. My suspect is this is a software problem (metal & gpu compatibility) as it behaves this way only when using certain apps especially those that use the GPU heavily or those that rely a lot on RAM. IDK

这个答案有帮助吗?

按维修分数 0
添加一条评论

添加你的答案

Carlos Ferrari 将永远感激不已
浏览统计数据:

过去的24小时: 2

过去的7天: 31

过去的30天: 163

总计 450