跳转到主内容

Second generation of the Toyota 4Runner.

35 个问题 查看全部

Why aren't my tach and speedometer working?

I just bought a 92 4runner that needs a fair bit of TLC. It runs well, but there are a few things that I'm leary of. 1st, I need to know how I can fix my speedometer and tachometer (note, only those two dont work. The rest of my gauges work fine).

2nd, (bonus question), how would I go about reconnecting my ebrake cable?

According to the previous owner, when he had the engine swapped (it was the 2.9, but he swapped it for the 3.4), the mechanic simply didnt reconnect the sensors for the tach/speedo. Additionally, by what he said, the ebrake was disconnected for some work he did himself, he just never got around to putting the cable back in.

Just in case it makes a difference, it's a 5 speed manual, 4x4. Anything anyone needs to know, just ask.

已回答! 显示答案 我也有这个问题

这是一个好问题吗?

得分 0

评论:

Have you reconnected the sensors?

完成的

I suppose I should've clarified: I was more so asking for info on their location. I've looked and cant find them.

完成的

The first thing you need to do is make sure that the fuel lines are disconnected and put the cap back on. Turn your vehicle off and then try again. If you still have no luck restarting your engine and turn your car off again. This should reset the fuel pump allowing the fuel lines to reattach and start working again.

完成的

添加一条评论

1个答案

已选择的解决方案

I am not so sure about a single sensor. Your Speedo and tach are on different “sensors.

RPM signal system

Crankshaft position and engine RPM are detected by the pick–up coil installed inside the distributor. Crankshaft position is input as a control signal to terminals G1 and G2 of the engine control module (ECU), and RPM is input to terminal NE.

 (6) vehicle speed signal system

The vehicle speed sensor (speed sensor), installed inside the combination meter, detects the vehicle speed and inputs a control signal to terminal SPD of the engine control module (ECU).

So check your ECU connectors

The attached wiring diagrams etc. should also help you to get started with a better diagnosis.

Document:Document:

这个答案有帮助吗?

得分 4

评论:

So if it's a sensor issue for speed, I'd have to replace the full combination meter?

Could it possibly just be that he bluffed and it's a bad gauge cluster? I've read this year seems to go out between 175k and 190k. It's at 204k.

My fuel, temp, oil, and battery gauges all work. But excluding those, a dying cluster could affect the tach as well, could not it?

完成的

Yes sir of cause it can. Check the documents I've attached. It will show you how test the cluster with a multimeter etc.

It is always tough to narrow things down when someone else made changes to the system etc. So you really have to check carefully.

完成的

My gas gauge Rach and speedometer all of them not working very confused

完成的

@Patrick Batiste sounds like an issue with the instrument cluster. did you download the documents to check the wiring etc.?

完成的

添加一条评论

添加你的答案

Synth Wolfe 将永远感激不已
浏览统计数据:

过去的24小时: 1

过去的7天: 10

过去的30天: 42

总计 1,014