Bizarre Battery Replacement Problems on *Two* Model A1278 Laptops

I have a 13-inch Macbook Pro, Mid 2012 (Model A178) with a 2.9GHz dual-core Intel Core i7 processor ("Computer 1"), and I recently purchased a nearly-identical laptop from Ebay with a 2.5GHz dual-core Intel Core i5 processor (as a Christmas gift to my fiance) ("Computer 2").

Last month, I upgraded some of the hardware in both machines:

  • Computer 1: I installed a Crucial 2TB SSD (CT2000MX500SSD1(Z)), 16gb of RAM from, and replaced the hard drive cable and battery, both purchased from ifixit.
  • Computer 2: I installed a Crucial 500gb SSD (CT500MX500SSD1(Z)), 8gb of RAM from Computer 1, and replaced the hard drive cable and battery with ifixit components as before.

On both SSDs, I did a clean install of macOS Sierra (installer was downloaded July 2018). (I installed the OS on the new SSDs externally, in USB hard drive cases, before installing them in the laptop. I then selected the new drive as the default drive after booting up for the first time. Lastly, I enabled TRIM support from the Terminal.) After the upgrade, I downloaded and installed all the updates available from the App Store.

With the old, original batteries, everything works great. Both computers charge and discharge normally, and they boot and turn off quickly. But with new batteries (both the ifixit brand and refurbished Apple batteries from an Apple-certified computer shop), I run into problems. The computers will initially boot fine, but if they are used more than a few minutes on battery power, they randomly shut off. If I allow the computer to charge to 100% while turned on, it will shut down after the MagSafe turns from red to green. After a subsequent reboot, the sleep light blinks for or five times, and there is an "X" over the battery symbol. Removal of the MagSafe at this point shuts down the computer. Resetting the SMC only temporarily fixes the problem: it puts me back at "step 1," but the problem repeats during the next use or charging cycle. I've also tried resetting the PRAM on both.

To make sure it wasn't a battery calibration issue, I spent a few days trying the following fixes ( I would reset the SMC, reboot, then turn off and unplug the battery. After sitting for 24 hours with no power, I would reconnect the battery, and plug in the MagSafe without booting, to let the battery charge to 100% while the computer was powered off. During the charge cycle, while the MagSafe was red, the battery indicator light would come on if I pushed the button. Once the MagSafe turned green, however, the battery indicator light became unresponsive, and the computers would not power on without the MagSafe plugged in. Booting with the MagSafe plugged in would result in the blinking sleep light and the "X" over the battery symbol.

So it seems that the battery is no longer recognized once it reaches full charge.

I took both laptops to an Apple-certified computer shop (not officially an Apple store, but endorsed by Apple), and they had had the same problems with genuine Apple refurbished batteries, but did not have any troubles when they booted into the recovery partition. They could leave the MagSafe plugged in 5 minutes after turning green and still run on battery power. First, they suspected a freak error in the OS, so they did a clean install of Sierra (with a new installer) on Computer 2. That didn't solve the problem, so they then looked at the hard drive cable. Booting my SSD from an external drive solved the problem, and booting another drive on my internal cable replicated the problem. However, a new internal cable with my SSD did not solve the problem. Last, they found a November firmware update for my SSD (for Windows), and built an installer to update the SSD firmware on Computer 2. That also failed to solve the problem, so they put the old batteries back in both computers and gave me a refund for the replacement batteries. They said it could be a specific niche problem, but that they would keep researching it. (The custom firmware broke TRIM functionality, so lastly, I had a friend restore the original SSD firmware and do a clean install with the latest version of the installer.)

The tl;dr summary: It doesn't seem like the logic board would be bad, because

  1. The old, original batteries work fine
  2. I have identical problems in both computers

I've looked up firmware updates for both the boot ROM and the SMC, but when I try to run them, I get the message "This update is not compatible with your system." I've suspected that installing the OS externally with an older installer could had led to some firmware problems, but I don't know what to do. I'm considering bringing one to a real Apple store (but removing my old battery first so as not to lose it). I can afford to do a clean install again on Computer 2, but I can't anymore on Computer 1, as I've since installed a lot of complex software with registration keys that won't migrate well in a Time Machine backup.

Block Image

Block Image

Thoughts? Thanks much.

回答此问题 我也有这个问题


得分 2


Lets look at both with a better tool. Download and install this gem of an app: CoconutBattery. Take a snapshot of the main window with the MagSafe connected and again with it removed so we can see the charge and discharge values. Post them here for us to see 在已经存在的问题里加入图片

You may want to look at your MagSafe chargers condition make sure the cord and the connector are in good shape if either is damaged don't use it as tit can damage your system. Review this Apple T/N Apple Portables: Troubleshooting MagSafe adapters


You do need to be careful with newer MacOS installs. The installer now updates the systems firmware so I would make the effort to run the Installer again it will refresh the OS files it won't alter your Apps or data. You did talk about running the updaters when did you do them once the SSD was installed or before? If you did it when the SSD was in the system then you will have gotten the needed firmware updates.

For the future instead put the new drive in and use your old drive in the SATA to USB case. That way when you do the OS install the system gets done as well.