iPhone 3G是第二代iPhone。型号A1241,有8或16 GB容量,和炫酷的黑色或洁白的白色塑料背面。修复比第一款iPhone更简单。需要螺丝刀、撬撬工具和吸尘工具。

1501 个问题 查看全部

Cannot Restore 4.2.1 6.15.00 base band. Need help.

Guys, im having a problem with restoring my iphone back. i have an iphone 3g 4.2.1 with bb 6.15.00. The problem is that, whenever it reaches "verifying iphone restore with apple" it just stay there and also the progress bar changes its color, its a little darker than usual but the apple logo stay the same..

what could be the problem?

since im using a custom firmware, could be that apple found out im using a CFW and that they are blocking me from restoring?

can i use saurik's server? im not sure if thats still working or something...

really need your help guys!!

thanks in advance!

已回答! View the answer 我也有这个问题


按维修分数 0


how to enter DFU mode when your stuck at recovery mode??? i get error 21... what i do to get to dfu mode.. correct me if im wrong.. when i plug my iphone the apple logo shows up then i hold the power and home button to turn the screen off.. i then repress the buttons and start to count 1-10 then itunes detects it but i end up error 21.

my second way is when iphone logo shows up when i pulg it.. i hold the home and power button until the screen turns black and count 1-7/8 and wait till itunes detect my phone..

help me...

You need to put iPhone into Pwned DFU, not DFU. To get Pwned DFU use one of the following three programs, Sn0wbreeze, Redsn0w, or PwnageTool.

i always end up either error 1611, 14, 21... recently im trying to restore using custom fw 4.2.1 by snowbreeze.. now.. im getting error 21 with white screen..


所有超过US$100.00或包含 Pro Tech工具包的订单免费送货!




When you are at Recovery Mode, like it seems you are right now. Use program TinyUmbrella. Open TinyUmbrella on computer, then connect iPhone to computer, then click on your iPhone name in TinyUmbrella, then click Exit Recovery button in TinyUmbrella.


按维修分数 1


i still end up at the recovery mode... i wasnt able to finish the restore since it stucked at "verifying iphone restore" as i mentioned before.. thre progress bar turned dark on my iphone then it just stayed there... i was around 97% complete that time..

i used 4.1 from felixbruin.de when restoring from 6.15.00. no problems.

@polly i did download that.. how will i restore? shall i use the redsnow to put it in pwned dfu or i go with the normal dfu mode?

im a 3g user... is it possible for me to restore without shshs??

you need to open itunes and then alt+select(mac) or right click+select(windows) the custom firmware. I just put in normal dfu.. brad is far more knowledgeable about this sort of thing.



Are you restoring from DFU mode? I believe that you need to do that when restoring a custom IPSW. Are you "Hacktivating" it, or do you have an AT&T SIM installed in the phone?


按维修分数 0


yes i am.. im using redsnow to put it in pwned DFU mode. i think im hacktivating since im using a custom fw.. but not so sure.. i also tried using snowbreeze CFW.. still the same result, i cannot finish the restore.. the progress bar changes its color and it just stays there..

also, im using the latest itunes 10.2.2 but i read some post that its compatible with jailbreaking and stuff...

the reason for me to restore it because my phone started to hang and everytime i sync to itunes my phone gets stuck at the "sync in progress" screen..

also some of my apps(free and cr@ked) are crashing...

Do you have an AT&T SIM installed in the phone while updating? If you have a 3rd-party SIM installed, (T-Mobile, O2, ect.) remove it, and put in the AT7T SIM.

i dont have an AT&T sim... i left my sim installed when i updated my phone.. did that cause the problem?

are you using a powered hub to do the restore? are you sure your battery is fully charged before starting?



Try these:

1. Try a back USB port

2. Make sure you run the latest iTunes version.

3. kick your device out of recovery using "exit recovery" button in tinyumbrella. Download here:


4. Enter DFU

5. Restore your custom FW


按维修分数 0


how do i enter dfu after i kick it out of recovery mode??.. it still returns to recovery mode.. and now i get black and white screen.. :-( restore it back to CFW 4.1? im a windows user... snowbreeze?

markeeinsik, I do use iReb on my widows OS to kick my ipods as well as iPhones out of recovery give it a try http://ih8sn0w.com/index.php/products/vi...

i did not get the 1015 error... so, no reason to kick it out of recovery..


markeeinsik, I do use iReb on my widows OS to kick my ipods as well as iPhones out of recovery give it a try http://ih8sn0w.com/index.php/products. Just to make sure we are all on the right page, without insulting you or anything, here are the instructions for the DFU. "Connect the iPhone to your computer and launch iTunes Turn the iPhone off (hold down the power button at the top of the iPhone) Hold down the sleep/power button and home button together for exactly 10 seconds, then release the power button Continue to hold down the Home button until a message appears in iTunes telling you an iPhone in recover mode has been detected iphone itunes dfu mode When you are in DFU mode your iPhone screen will be completely black iphone dfu mode Even though the screen is black, that doesn’t mean the device can’t be interfaced with either iTunes or a custom firmware client (for jailbreaking, etc). Remember that if you see the restore logo, iTunes logo, or any message on the iPhone screen, you are not in DFU mode but standard Recovery Mode. Again, DFU mode is signified by having a completely black screen on the device. If anything else is the case, repeat the steps above until you enter into DFU mode successfully. Exit DFU mode on iPhone The simplest way to exit out of DFU mode is to hold down the Home and sleep/power buttons on the iPhone while connected to iTunes. Then just hit the power button as and this should reboot the device as usual." There is more on here Good Luck


按维修分数 0


my problem is i cannot turn off the phone since everytime i turn it on, its stuck at the recovery mode...

Let ireb kick it out of recovery mode. Just follow the instructions for the program.

the history of the phone is.. i was restore back to 4.2.1 and baseband 6.15, i encountered some crashes and decided to restore it to 4.1.. it worked.. then i tried the SAM method.. but i was unstable, keeps my phone rebooting.. then i tried to restore it on both 4.2.1 and 4.1 custom firmware snowbreeze... but now i wont restore.. i always get error 21 when restore to original 4.1.. even when pwned with redsnow... if i kick it.. it just return to recovery mode..


Buttom line is:

Stay with your current Firmware/version and instead of SAM, pay 5$ for pushfix - see here:


good luck :)


按维修分数 0


markeeinsik 将永远感激不已

过去的24小时: 1

过去的7天: 2

过去的30天: 6

总计 5,426