The Stealth Pro is a gaming laptop manufactured by MSI. The GS63VR 6RF is a 15.6" model, released in 2016.

10 个问题 查看全部

GTX 1060 uses only one PCIe lane for some weird reason...

So, hi, everyone… Weird question for tl;dr band… Does someone know how to rewrite some certain variables in BIOS so that GTX 1060 could use x16 again and not x1 only? Or there’s something else involved, too?

All I ask is does someone know a way to fix this issue with EFI Shell or something similar that can manipulate with BIOS FW… And yes, I know that Anti-Static wrist wraps help not damage electronics, but for that I have a lamp that has metal body… SO DON’T ADVISE ME TO BUY ONE! I’m in such financial situation where every rouble counts…

Just to be clear, DDU + old drivers didn’t help, flashing laptop’s BIOS didn’t help, just as fresh install of Windows 10, new drivers and factory reset… Oh, and yeah, there was no damage found by repair technician on MoBo… And yes, AC Adapter is Plugged in, Power Plan was set to “High Perfomance Mode”… I mean, I AM an idiot to some degree, but not that idiotic.

Now here are some details…

In February I decided to change thermal paste in my laptop in order to lower temperatures to somewhat acceptable (I used MX-4, if you’re interested).

Then I launched AIDA64 and FurMark in order to test cooling perfomance at it’s peak (yes, I know that it is a lot, but I want to get into 3D modelling, so, yeah). Started stress test in AIDA64, then I tried to launch FurMark… That caused Windows to completely freeze, so I was able to shut it down only by holding the power button long enough… After that I boot into Windows, see that GTX 1060 isn’t recognized, sweared a lot, used DDU and last drivers atm, run FurMark and AIDA, everything looks okay.

Decided to fire up Hellblade just to play a little… For no particular reason, fps dropped from stable 60 to high 20s… 1080p Very High (except for a few settings)… Asked everyone else, they said their fps seems normal, even with new drivers (which is what I initially thought could be a problem, remembering that Meltdown and Spectre fixes came just at that moment).

Block Image

Those are results in DiRT Rally, 1080p Ultra…

So yeah, after I realised it’s not one game, I decided to lower settings in DiRT Rally to see, if there will be any improvement. 720p, Low… Nope, still bad minimum fps, avg wasn’t that better, too…

Block Image

Temps weren’t a problem, too… They were even higher with playable framerates before…

So I fired up GPU-Z, and… “WUT?! WTF?!”

Block Image

Here’s the problem… Only PCIe 3.0 x1 lane is used… Not 8 or 16… Ok, Fire Strike next and… Sh!t…

Block Image

That wasn't good… Combined score should be in 14-15k zone…

After that I tried to flash a new BIOS (not VBIOS), asked for looking for any physical damage… No, not a thing.

Ok, fresh Install of Windows on a new SSD… Ran some tests and… F-Bomb…

Block Image

Block Image

Block Image

After painstakingly trying to figure out ways to test that in Manjaro (which didn’t happen, but was worth a shot) I decided to give UEFI Shell a try… Maybe it can show something… And showed it for real…

Block Image

Nothing interesting here…

Block Image

And there…

Block Image

Wait… What’s that under Link Status (12) D013? x1? WHAT?! What the !&&*?

Block Image

Wait, power limit is scaled, too? The !&&*?

Block Image

Last page, nothing interesting here, too, I suppose…

So, here’s the real question… What should I do next?

回答此问题 我也有这个问题


得分 0

Because it’s always best to start with the simplest things first. You opened it up and did stuff and now it doesn’t work, so retracing your steps and double checking the reassembly is a prudent first step.

Did you use static protection when you had it apart before?


No, since I don't have it (and won't have it since I don't have enough money to buy everything small I might use only once a month). But that's not the freakin' case (since I never use it any way because I don't have a problem with static charge thanks to metal details outside of PC that help me discharge myself and wooden table that doesn't transfer that charge)... And I ALREADY DID SIMPLE THINGS, OTHERWISE I WOULDN'T ASK... And it was working, until I tried to run AIDA64 with FurMark simultaneously... So yeah, I traced my steps well enough...


The problem is either in MoBo physical damage that is hard to find, or in BIOS software. Hoping for last, since that can be managed w/o repair technicians somehow...


@spakes people are trying to assist you. No matter how useful you find it, there is never any reason for name calling or profanity. Time to cool those jets....


@oldturkey03 I see that they try to help, but it's more like disservise in this situation. Especially when it's written in decent english that someone's suggestion didn't help.





Take it back apart. Re-seat everything. Check ribbon cables. Make sure you wear static protection this time.

My fingers are crossed for you bud.

Block Image

Anti-Static Wrist Strap图片


Anti-Static Wrist Strap



得分 2


@kingspc the avatar, please give us a break and change it to Rodney Dangerfields "I don't don't get no respect"



Use compressed air to clean the GPU area out really well. If that doesn't work, there are a innumerable things that it could be so I would suggest starting simple and checking that the power supply supplying the correct voltages under-load.

Also, for what it’s worth: Anti-static wrist straps will only set you back between $2 and $5. It’s pretty good insurance against damaging multi-hundred dollar equipment. Discharging into the chassis is a good mitigation, but you have to keep re-touching it as you work or else your clothes will build up a charge. Some microprocessors will die from a zap that you can’t even feel. The wrist strap goes on your wrist, the clip gets attached to the ground-plane of what you are working on (PCI bracket when working on the card, Chassis when working on an assembled PC, screw hole if working on a bare motherboard).


得分 1


Did you even check what you're talking about is going to work in my case?..


And yeah, already tried compressed air while cleaning my laptop. Nope, not helping (since it's BGA design aka soldered)...


I meant the logic board's circuits, but if you are going to act like that about suggestions you won't get much help. I was willing to walk you through doing the testing.

The AC adaptor might be fine, but once that voltage goes into the system it is regulated into separate 1.5v, 3v, 5v, 12v rails that are used to power the components of the system.

There are many things that can go wrong when you are messing around with a laptop logic board, especially when removing/reinstalling heatsinks and heat pipes. A lot of people cause damage to the chip or board without even realizing it due to the leverage provided by the heatsink structure during removal. One thing I read when researching your issue was that, when not supplied with enough voltage, the GPU might show as a PCIe 1x device as well as other instabilities.

Good luck.


Also, Ball Grid Array packages do have some spacing between them and the board, as well there are other components in the area that you worked on that could have some particulate matter causing a minor short. I get that you said you tried dusting it, and if it didn't work it didn't work. There is merit to these steps, if you can allow yourself to see beyond your frustration.


Essentially, we all are saying that it seems like some sort of a hardware failure, most likely related to static discharge. We aren’t trying to diminish you or your troubleshooting abilities but we don’t know you from Adam and you didn’t mention the things we suggested in your original post. Good luck friend, I hope you get it figured out.


@geekittogether That I know. However. relay seems to work fine (tested that with HWInfo64). Well, let's hope that another repair technician will find something in January.

@kingspc Well, seems like I mentioned them not in a straight way, and hoped that common sense would work. For that, I'm truly sorry (MDD certainly doesn't help with frustration, but it's not the point). I guess, my expectations are one !&&* of my problem also... Thank you, I'll definetely need that luck.



Normally I would not advise that you use these special unlocked bios settings, but this MIGHT help

you in this particular situation…

WARNING: doing this could possibly brick your PC, burn down your house, kill your cat, or WORSE….


DISCLAIMER: Do this at your own risk! I am not responsible if you brick, lock up, damage, fry, let smoke out, burn up, blow up, ect your computer (or your cat)!

  • BACKUP YOUR BIOS,, hard drives,vrams, video bios, and the cat’s litterpan.



boot your laptop into bios settings

now while on main bios screen, press and hold three keys at the same time:

Right Shift

Right Control

Left ALT…

NOW Press F2 while holding those 3 buttons,

Advanced BIOS Menus will show up

GO BACK UP YOUR BIOS SETTINGS ONE MORE TIME (especially if you never did it in the first place)

Stop, and seriously think about how these settings can totally hose up/brick /render inoperable your computer…

Go feed the cat/bio break/get a snack.

I am not sure where exactly in all these pages of settings the PCIexpress bus speed setting is at, but I know I saw it in there somewhere… you will have to look for it. DONT CHANGE ANYTHING ELSE. Make one change, document what it was before, and what you have changed it to, and which menus got you to the setting. WRITE IT DOWN.

AFTER making your changes, press F10, select yes to save settings, reboot pc.

See if that worked for you. if it did, give me a thumps up/like, etc. NOW GO FEED THE CAT!

IF IT DID NOT: carefully go back into bios and change it back and resave settings/reboot. Only then can you try a different settings change. REMEMBER: one at a time, SAVE, REBOOT.

Hope it HELPS.


得分 0


Kirill Virt 将永远感激不已

过去 24 小时: 0

过去 7 天: 0

过去 30 天: 4

总计 506