型号:A1419/ 2012/2.9 & 3.2 GHz Core i5 or 3.4 GHz Core i7 专业版

207 个问题 查看全部

How can I be certain the logic board is good/bad

Hello,

Our iMac lost its’ HDD shortly after warranty had expired.

We have never had Mac that didn’t croak so I always have a fresh boot disk that is created every other day. We have recently (about a year ago) had trouble where the external wouldn’t even boot. Booting into boot manager the only options were for an internet recovery.

I was able to try all boot options and finally the external boot drive would after having unplugged everything and gradually plugging everything back in.

Fast forward ahead a few months and the only way to restart is via boot manager (option key) but it was reliable. Fast forward ahead a bit more and not only did my external boot drive appear but also the internal HDD reappeared! I was even able to boot from it and back up the contents before it disappeared again.

We are now in a state where boot manage works SOMETIMES but only if I unplug everything, start boot manager then add the external drive while boot manager. Oh and the internal HDD is back but the computer freezes I try to boot with it. Sorry for the belabored end of this question.

Basically, it’s like the whole data bus just drops out of sight. I have tried USB, Thunderbolt connections and when having issues the computer sees no drives at all. I want to assume it is the logic board but how can I tell ultimately?

Thank you so much.

已回答! View the answer 我也有这个问题

这是一个好问题吗?

按维修分数 0
添加一条评论
Spread Fixmas Cheer
Get $12 off your purchase of $50 or more with code FIXMAS12
Spread Fixmas Cheer
Get $12 off your purchase of $50 or more with code FIXMAS12

3个回答

已选择的解决方案

Here is the answer folks… The croaked HDD that was still in the machine and connected was creating chaos on the data bus or so it appears. I disconnected it and SSD boot drive and the thing booted in 10 seconds. On my way to prepping new larger HDD to install in the machine. With Apple being Apple I'm expecting some boondoggle once I connect new spinning drive for it's first boot. Check back in a couple of hours if interested.

这个答案有帮助吗?

按维修分数 1

评论:

So you have a Fusion Drive config!

Ah ha! That's your problem!

No Fusion drive here. OEM was 1 TB spinning Seagate Barracuda that died just out of warranty. As I said, this was not the first Mac that had a failure on the internal hard drive. I have been running dual Samsung EVO 250s externally for a while but this week end my wife's piece of iMac decided it was going to boot for nobody under any circumstance. After opening it only to see all LEDs green I applied the WTF filter, and starting plugging drives. Since my SSD booted with no issues, I cloned it with SuperDuper! onto a 2TB Barracuda I had sitting on the shelf and here I post this comment with the restored system. All I need to do is get some foam tape so I can seal it up properly.

添加一条评论
最有帮助的答案

What are the diagnostic LEDs telling you?

iMac Intel 24" EMC 2134 and 2211 Diagnostic LED's

Here’s the LED’s placement and assignments

Block Image

这个答案有帮助吗?

按维修分数 2

评论:

I guess you answered my next question. Thanks.

Wow! I must be a mind reader. You're very welcome!

@ajcooke01 - Keep in mind the diagtnostic LED's are in a different location in this system.

@danj I'm not an expert when it comes to this system. I didn't want to send the OP on a wild goose chase trying to find them.

@ajcooke01 - Sometimes its best to leave the question for someone else.

显示更多的1条评论

添加一条评论

You may want to check your power cord, the power strip (better yet surge suppressor or still better UPS) as well as your outlet. Make sure your outlets ground connection is good and the blades polarity is correct using a outlet tester. You’ll also want to check the voltage at the outlet as well. I suspect your issue maybe related to your power/grounding service.

这个答案有帮助吗?

按维修分数 0

评论:

Well, I'm running a makeshift setup with my boot drive on a Mac mini with all other external drives connected on the same outlet/power strip as the iMac with no issues. The outlet is @ 117 VAC with a good ground (according to the surge protector connected to it). I don't have a tester to check the polarity or verify the ground but I'll go get one tomorrow and retest.

I went ahead and cracked open the iMac (you talk about dust...). Powered by a separate 117VAC outlet with a good ground I have had to go through the same dances/ rituals to even get it to recognize a drive. All LEDs on the board glow green all of the time. The only other thing I can think to try is powering it up from a 12v/120 VAC inverter. Any other ideas?

Thanks

添加一条评论

添加你的答案

bufordk 将永远感激不已
浏览统计数据:

过去的24小时: 0

过去的7天: 0

过去的30天: 50

总计 50