Released October 24, 2011 / 2.2, 2.4, or 2.5 GHz Quad-core Intel Core i7 Processor

352 个问题 查看全部

AirDrop is not functional, could I swap the AirPort Card?

I’ve had this Late 2011 15” MacBook Pro for about a month now (got it off my Uncle) and I use it nearly day to day.

Just recently, when I wanted to share pictures from my iPhone to this specific Mac via AirDrop; my Mac would not show up in the AirDrop menu no matter what I did.

  • I went to finder and to the AirDrop page, waited 10 minutes on that page to no avail
  • Double checked the AirDrop settings on my iPhone were set to everyone
  • Installed Mojave, Lion, Sierra, High Sierra to no avail. This is not a software issue I could now tell.
  • Triple checked that it wasn’t a software issue or just my iPhone by getting my 13” version of this MacBook Pro and tried AirDropping files to that Mac, it worked, I received the pictures from my iPhone…

My question is that because I have a 13” Late 2011 MBP, could I just move the AirPort Card in the “13 over to my 15” late 2011 MBP? Are they cross-compatible or do I need a specific card for the 15” MBP?

Thanks in advance!

Update (11/03/2018)

Okay, I did some research on the cards and I do see they are indeed cross-compatible. Before I spend my time doing this swap, would swapping cards solve my problem?

Update (11/03/2018)

I just swapped the AirPort boards. No dice. AirDrop still doesn’t work. I am skunked on this one. No security settings are preventing AirDrop from running.

已回答! View the answer 我也有这个问题

这是一个好问题吗?

按维修分数 0

评论:

why do you think the airport card is the problem? is it not connecting to internet?

@pollytintop The AirPort Card is how a Mac receives “airdropped” files. If it’s malfunctioning or if you damage it, you’re out of luck. It still connects to the internet and Bluetooth works OK.

Also, I wouldn’t be spending a dime on swapping these cards.

添加一条评论

所有超过US$100或包含 Pro Tech工具包的订单免费送货!

浏览我们的商店

1个答案

已选择的解决方案

so you kind of answered your self... the airport card works, why swap it? the fault must be somewhere else, frustrating. Sometimes on these older machines the answer lies in the network settings themselves. IPV6 isn't supported or something like that...

go to airport settings>TCP/IP>turn “configure IPV6” off , see if that works

这个答案有帮助吗?

按维修分数 2

评论:

I’ll take a peek at those settings

@pollytintop nope, did nothing. this is definitely not a software issue...

what else apart from the updates did you try?

firewall settings? check your security settings

@ajcooke01 open the network settings on your known working mac and copy everything to the other one. Check bluetooth permissions.

显示更多的4条评论

添加一条评论

添加你的答案

Aaron Cooke 将永远感激不已
浏览统计数据:

过去的24小时: 0

过去的7天: 0

过去的30天: 6

总计 83