Replaced broke bottom casing, now it won't turn on

Short version: replaced a casing, had to open up the bottom portion and part of the top in order to get it back together, now the only sign of life it has is an orange light that turns on for about a minute when I plug in or press the power button before going dead. No popping sounds.

Long version: Broke off the plastic covering the hinge on the right side, over the button pad. I was tired of the duct tape look, and figured I had already replaced the small joystick with no problems, so I bought an oem casing off eBay to replace it myself, not realizing I'd have to open up the top case.

After getting everything back together and accounted for, the dang thing doesn't power up, even when I press the power button for 30 seconds. The only thing it does is turn on the orange charging light for about a minute or so, then turn off. Pressing the power button makes the same response. Same responses when I plug it in without the battery in place, or have the memory card taken out.

Checked to make sure everything was in place, and it seems to be to my novice eye. Here's a photo to hopefully help things. I can post more if needed.

Block Image

回答此问题 我也有这个问题

这是一个好问题吗?

按维修分数 0

评论:

Had this same issue happen on a repair a few months ago.

Make sure all of the ribbon/flex cables are seated properly, and check each for dings or damage.

Thanks! I'll check later on. did notice that one of the ribbon cables is hard to figure out how to set properly. It's the top thin one in the set of three on the top corner (the middle corner in the photo). What have you done to ensure it doesn't get bent improperly?

Using ceramic tweezers to place the cable, I opened the housing to the maximum angle when placing the cable into the port. Try to be as gentle with the cable as you can to not get any un-necessary kinks or bends.

Hm, yeah. I wonder if there's some kind of kink in one of the ribbons. I carefully took every cable out, swabbed them and each housing with 50% rubbing alcohol just in case, then placed them back with tweezers. Still the same response.

The one ribbon I think may be the culprit is the thin one by the game cartridge slot. I missed pulling it back when i placed the motherboard in my first attempt, and tried to ease it out using my spulger.

Also, I have not put all the screws back it to make sure I don't strip the screwheads, so if that may be an issue, let me know.

Some updates:

- Tried redoing the seating just in case, but have had no luck.

- I tried pressing L+R+Up+A+Power, and that made the charge turn on for a length of time. I'm going to let it charge until it turns off, then see if holding down the power key will make it finally turn on.

添加一条评论