跳转到主内容

White Screen, External Monitor works - LCD panel works

Hi All,

So bit of a strange one. I bought a ‘spare or repair’ MacBook Pro early 2011 (13” i7) thinking it had a potentially broken screen. To use it to repair my MacBook Pro late 2011 (13”, i5) thinking of doing a motherboard switch..

It turns on, white screen is displayed, chimes. I can attach an external monitor and login fine so it all seems good. I ran ASD and it returns no errors.

So I figured the LCD panel must be broken, so I took it off and tried it on my other macbook - and it works fine.

The fact that it works on external monitor tells me its not a GPU issue, and nor is the panel itself thats broken. There doesn’t appear to be any water damage or corrosion and the connector to the mother board looks fine to me.

Any ideas?

Edit: I have also done the obvious SMC, PRAM resets and booted ASD from a USB drive

Some photos of the board and connector (not the best as I was just using my phone)

Block Image

Block Image

Block Image

Block Image

Block Image

Connector photo again:

Block Image

已回答! 显示答案 我也有这个问题

这是一个好问题吗?

得分 0
添加一条评论

2个回答

已选择的解决方案

My problem was solved by replacing the L9004 inductor.

Funnily enough I managed to blow that on the other working MacBook whilst probing with multimeter. So I replaced it on both board and it solved the screen issues.

这个答案有帮助吗?

得分 0
添加一条评论
最有帮助的答案

Sounds like its either the wrong screen for this system, or the logic board/ribbon cable is damaged.

You might what to run down the P/N’s to see if it’s the correct logic board for this system as well as the display, if that comes up clean then take some detailed images of the logic board connector and the ribbon cable and post them here so we can see if there is some damage 在已经存在的问题里加入图片

这个答案有帮助吗?

得分 1

评论:

Hey thanks for the response. I may not have been clear. Ive not actually moved the motherboard or anything over yet, as I want to make sure I know what's wrong with it first.

So as it stands, i took off the LCD and tested it on another machine and it works fine on there. But does not work (gives a white screen) on the MacBook that it came from. So it's not a parts incompatiblity thing.

Will try and get some images up shortly.

完成的

It might be the reason the system was sold as it wasn’t working. In any case take some good images of the connector and cable as that would be the first thing I would check.

完成的

It was sold as 'screen not working;, but I was hoping it was the screen itself rather than the logic board.

I've added some photos to the original post

完成的

Well the logic board does look clean! Except the LVDS connector looks like someone replaced it as the soldering looks iffy. If you pop off your systems bottom cover to take a look at yours you'll see the difference. Hows your soldering skills?

The tang of the cable connector looks OK, so it's looking like the logic board needs attention.

完成的

I think that photo was just bad as I took it with the flash on. I've added another with better lighting and to be honest it looks ok to me.

完成的

显示更多的4条评论

添加一条评论

添加你的答案

Tom 将永远感激不已
浏览统计数据:

过去的24小时: 2

过去的7天: 3

过去的30天: 9

总计 1,041