跳转到主内容

Repair guides and support information for televisions manufactured by RCA.

81 个问题 查看全部

Why is the RCA LED55C55R120Q TV Screen Only Showing the Backlight?

I picked up a free RCA LED55C55R120Q TV that the screen is only showing the backlight when powering on as well as on the front cover the Red LED solid (is off when powered off).

I’ve unplugged the Frame Rate Control (LVDS) board and power supply to the LVDS board and still the same scenerio.

I read on ifixya a protocol that I am not finding, and forgot to print out, where the first step was to unplug the T-Con board and if the backlights still power on, then replace the T-Con board. I did this also.

Furthermore, I found a “100” Inductor loose inside the set as well as the base being screwed in with some strange looking sheet metal screws thankfully not fully since the threads for the base are not that style. I’m not sure and can’t see where that inductor would come from.

I’ll check voltages next.

Here are the images of the boards:


Power Board:

Block Image


Block Image

Block Image

Block Image

LVDS Frame Rate Control (FRC) Board:

Block Image


T-Con Board:

Block Image

Block Image

Block Image


Main Board:

Block Image

Block Image


LCD Screen:

Block Image

Lone Inductor:

Block Image

I picked up another free RCA LED55C55R120Q TV that the screen is only showing the backlight when powering on as well as on the front cover the Red LED solid (is off when powered off).

I’ve unplugged the Frame Rate Control (LVDS) board and power supply to the LVDS board and still the same scenerio.

I read on ifixya a protocol that I am not finding, and forgot to print out, where the first step was to unplug the T-Con board and if the backlights still power on, then replace the T-Con board. I did this also.

Scenario Two (Same though different boards):


Power Supply Board:

Block Image

Block Image

Block Image

Main Board:

Block Image



FRC Board:

Block Image



T-Con Board:

Block Image

Block Image

回答此问题 我也有这个问题

这是一个好问题吗?

按维修分数 0
添加一条评论

PC 笔记本电池

An easy fix for a big power boost.

现在开始购物

PC 笔记本电池

An easy fix for a big power boost.

现在开始购物

1个答案

最有帮助的答案

The picture you have labeled as the T-con board is actually the FRC board. The T-con board should be marked with part number: SNB 12PSQBC4LV0.1 or something similar. The inductor seems to have come from the T-con board. Add in a picture of that one and I will try to describe where it goes. This repair could be as simple as replacing the inducter (wouldn’t that be nice!).

Add in the picture of the T-con board or replace it.

Dan

这个答案有帮助吗?

按维修分数 2

评论:

Thanks for the clarification regarding the Frame Rate Control (FRC) board. I’ll edit the post and update. I just finished testing voltages pwr on and off on the Power Supply board and looks all in spec. I’m guessing the T-Con board is behind the metal plate before the boards related to the LCD Screen. I’ll remove, inspect, photograph and report back.

Your second picture of the T-con board shows the place where the inductor fell off. There does not appear to be any damage to the board. Try resoldering the part back on. Match the placement with the profile on the board.

I resoldered the inductor in place and the LCD Screen is working now... though I noticed some ghosting at first of the "NO SIGNAL" box for a few seconds that goes away as it is moving.

The center of the screen appears to be a darker blue... though I didn't notice anything worse with the "NO SIGNAL" box as it moved through that region and the backlights seem to be as intense.

I'm wondering about Q101 and the traces there. That area looks like something circular ground against the board and I soldered two traces that looked like they were ground/cut. I didn't replace the Q101 transistor and I guess that will improve the image quality issues I'm observing.

I'll have to find a schematic or determine what the transistor is to restore better quality I'm thinking.

The LCD Screen Is working now! Thank you sir!

I thought that may have been some residue from a cotton swab or cloth. Any marking on the transistor at all?

I see also where the three sheet metal screws were used instead of the base mount screw in that same location... that might have been what screwed into the T-Con board and caused the circular pattern and broke the inductor off. I'm not sure how the circular pattern was made so large though compared to the hole diameter of the base mount plate unless the tip was offset at an angle though maybe a smaller diameter wood screw was used crooked or something first. Doesn't seem to make sense with the three sheet metal screws I found with loosely holding the base on.

I have another free LED55C55R120Q with the same symptoms and am going to measure that transistor and see if maybe I have a similar transistor on another video card or some salvage board.

显示更多的5条评论

添加一条评论

添加你的答案

James Finch 将永远感激不已
浏览统计数据:

过去的24小时: 0

过去的7天: 4

过去的30天: 41

总计 507