跳转到主内容

24英寸显示器,内置iSight 摄像头,麦克风和扬声器。 1920*1200分辨率。 发布于2008年10月 型号为A1267

78 个问题 查看全部

Diagnosis for A1267 Cinema Display with no USB but working MagSafe

So here is the rundown:

I got this display on Craigslist for cheap.

When plugging in, it supplies my 2011 MBA power via MagSafe but:

-The panel shows no signs of life

-System Report on the MBA doesn't register any external USB or iSight devices

When opened, the power supply has some residue on the front of the board.

Going through the deep dive for Dead Unit/No Power in Apple's technician PDF:

1. No

2. No, unless somehow the MBA 2011 11" isnt a 'supported system'

3. No voltage on TP11

4. No voltage on TP61

9. No voltage on TP61 or TP13

Conclusion: Replace logic board

So even though there is some residue on the power supply board, there still seems to be issues with the logic board.

When I unplug the 7 pin power connector from the logic board, it has these voltages from left to right, 0 - 7:

1. Nothing: zero volts to anything else

2. Ground

3. 6V to GND

4. 6V to GND

5. 6V to GND

6. 30V to GND

7. 30V to GND

I am left thinking that my Logic Board needs some help..

Please let me know anything else I can post to help with a solution

Thanks,

Timothy

Block Image

Block Image

已回答! 显示答案 我也有这个问题

这是一个好问题吗?

得分 0

评论:

Ive seen too many of these with logicboard issues. The PSU as bad as it looks it probably ok. The connector your measuring needs to be connected to the PSU to get a proper voltage reading. Most of these displays have failed gpu’s due to dust and heat. I would put the money you’ll use to replace the LB into something more relable, unless you want to disasseble it every 6 moths for a dusting.

完成的

But does a failed GPU prevent the USB and iSight from functioning?

完成的

添加一条评论

1个回答

已选择的解决方案

@warkentim have you cleaned your board yet? what do you have going on in those yellow square marked areas? Just some goop or what is that?

Block Image

Since you have no power on TP11 (I assume 12 and 13 neither) you are not getting power to the board. Check the transformer on the PSU to see if you get power to and from it. Looks like the PSU had some damage to that area.

这个答案有帮助吗?

得分 2

评论:

Thanks for the reply. I haven't cleaned the board yet.

I think the goop is some kind of insulating or protecting silicon on some components.

To measure the voltages on the transformer the ground probe goes on the screw hole rims right? And then look at all the components before it?

Is this something I can tackle with help here or should I go for a new PSU?

完成的

Yeah I figured it was goop justed wanted to make sure. Since there are no schematics for the PSU that I know off, it will be difficult to try to figure out what may have failed. Probably better to get a replacement. But hang on to the one you have just in case we come across more schematics etc.

完成的

添加一条评论

添加你的答案

Timothy 将永远感激不已
浏览统计数据:

过去的24小时: 0

过去的7天: 3

过去的30天: 3

总计 318