发布于 2012 年 6 月, 型号 A1278. Intel 处理器,支持 Turbo Boost, 最多 512 MB DDR5 显存

1623 个问题 查看全部

MacBook won't boot - no chime - black screen - fans on high rev

Hey Guys,

my macbook pro won't start at all. If I push the on button, nothing happens despite status LED is shortly bright, then (0.5 sec) dim. There is no chime, no screen, no capslock led when pressed. And the fans rev like !&&*...till I power it off.

Tryed everything of the obvious solutions... PRAM /SMC / RAM swaps etc. ...nothing

Is it a failing logicboard or a power issue (the logicboard doesn't get the signal to turn on ? )

Anyone any idea?

thx ;)

Update (04/09/2018)

Still no luck :(

回答此问题 我也有这个问题


得分 3

I am having the same issue like you. No solution yet. This is third time I get. Last 2 times I tried PRAM reset and it worked. But this time no response from machine. Plz help with solution if you have any.


Any update guys? I have the same issue and looking for answers


Umashankar Harindranath Rao & promila.matta00 - If your system is reacted in the same way you need to replace the logic board as the CPU and/or PCH chip has failed.


This has happened to me last night with my pro retina 2015 . It’s very frustrating


Same thing happened! Thought it was battery related, bought an ifixit battery and toolkit, 4 hours later, no change! I’ll never thought this would happen with a Mac!






i seen this on another page.

Just fixed MacBook Pro stuck in Sleep and Fans running high. All you need to do is open up case and unplug the fans from motherboard! Somehow the temperature sensing must be in fan air and it senses high temp and shuts down computer with fans on high. Some how restarting computer doesn't reset things (design fault or firmware bug). But UNPLUG FANS and you're good to go. I did this while powered on and it sprang into life! Later I checked it powers down and reboots. Don't forget to plug fans in again before completion and fans "hey presto" run at normal speed. Apple engineers couldnt fix this and said we had to buy new board or computer $2k+. Good luck


得分 1


Thanks for the advice...will try it when home ;)

Update (04/09/2018)

Still no luck :(


I have the same exact issue like yours.. how did u end up fixing it?



You may want to see whats going on with the thermal sensors & what the fan is doing. This is a good app to see them: TG Pro.

I haven't seen SMC get stuck on its own. But I have seen where I've needed to disconnect the battery to do a good hard reset can make the difference. Basically, disconnect the batter then hold the power button for a good 30 sec and reconnect the battery.

Update (04/10/2018)

Sorry guy sounds like your logic board is damaged here. If you can't start the system but your USB ports are working then you have a deeper problem within the logic board.

Did you get your system wet? Have a liquid spill or sit your system down on a wet surface at some point? These are often the cause. As the corrosive nature of what was spilled could slowly eat your logic board or cause a short.

The other possibility is a power surge damaged your system.

Update (04/13/2018)

Here's the IFIXIT guide you'll need to follow to replace your logic board: MacBook Pro 13" Unibody 2012末主板更换 and here are your possible choices:

MacBook Pro 13" Unibody (Mid 2012) 2.5 GHz Logic Board图片


MacBook Pro 13" Unibody (Mid 2012) 2.5 GHz Logic Board


MacBook Pro 13" Unibody (Mid 2012) 2.9 GHz Logic Board图片


MacBook Pro 13" Unibody (Mid 2012) 2.9 GHz Logic Board



得分 1


So I can't boot, no chance to run diagnostics app :(


Not even in diagnostic mode holding the D key?


No, when I hit the power button, only fans Rev at full speed, no picture no gong. Only the LED is on and gets dim. When I close the lid, the led is bright.

Next thing I think could be a thermal sensor that is dead so that the board thinks it's too hot and fans spinning at top speed to prevent overheating ...but where are the thermal sensors on the i5 board?

If I plug in my phone it charges...means that everything with Power supply is ok?

Thanks Dan, no water spill at all. Today took the logicboard out and checked it under microscope...nothing to see...no corrosion or burnt components. I know that sometimes you not see If a component is dead...but the board is clean as he'll for the 5 year old machine ;)

Last time it was on...installing El capitan an then on the half or so I got "graphical snow" like on old TV at the screen and it shutted down. Is there a possibility that the installation tried to upgrade SMC or EFI and couldn't finish so that they are now corrupted?


So now it's completely dead. Hitting the power button does not show white LED and the fans do not spin. Only HDD begins to spin and the MacBook will get warm. Charging and Battery indicator works ...also SMS reset. But does nothing :(


Sounds like you'll need a new logic board as the 'snow' is a sign the GPU is failing.




Oddly similar scenario with my MacBook Pro - no solution yet . . .

Okay, I came across this exchange after my 13” MacBook Pro went dead right in the middle of loading the OS. I had been using it all day without incident until it had become very laggy to to the point of being almost unresponsive. I was doing research and had a butt-load of open tabs in Safari I assumed were drawing hard on the resources. So. I pressed the start button and held it until the machine shut off, then rebooted. Everything appeared fine until we got to the part of start-up phase where I believe the graphics driver loads and takes over the job. The screen went black and then immediately blinked to a state where the bottom half was white and the top remained black with some intermittent white lines and artifacts where the white and dark parts met. To be clear, that is how it has always behaved at that part of the start-up. Normally, right after the screen flash to black and white within a split second apple the logo and progress indicator return and then the log-in screen appears. This time the screen flashed and remained dark. When I looked I realized it appeared to have completely shut off. So I pushed the power button again. The MacBook Pro chimed, began to load, and then same thing at exactly the same point, appeared to go dead. This time pressing the power resulted in no response. No keyboard lights, no chime, no fan… nada. I follow the instructions for every scenario I find online about the issue, no change. When I reset the SMC, the light on the power supply changes to green then back to amber indicating the SMC resets but still no action or response when pressing the power button. So just in case, I connected it to power and allowed it to charge all night. This morning - no change. The MacBook Pro USB ports charge when I plug into them and SMC responds to reset commands but the laptop still remains dead.

A couple of other detaIls: The magnetic power supply and connector are NOT OEM. And after charging all night, the light indicator on the power supply never indicates the battery charge is complete. This is a brand new OEM battery that only showed 53 cycles when I looked at the system report this past weekend.

My next steps are going to remove the bottom panel and disconnect the battery and fan cable to see if that makes a difference.


得分 0


BenjaminS 将永远感激不已

过去 24 小时: 0

过去 7 天: 5

过去 30 天: 38

总计 13,920