Cant restore. Itunes error "server does not support this version"

Cant restore my ipod. Beep when connected to Itunes but displays error "server does not support this version of itunes"

Have tryed 4 computers (windows and mac) so this is ipod fault. Also has happened before on a 4th gen.

Any sugestions?

已回答! View the answer 我也有这个问题

这是一个好问题吗?

按维修分数 1
添加一条评论
传播 Fixmas 欢乐
Get $12 off your purchase of $50 or more with code FIXMAS12
传播 Fixmas 欢乐
Get $12 off your purchase of $50 or more with code FIXMAS12

4个回答

已选择的解决方案

This nifty little trick has stopped all iTunes Error messages dead in their tracks. Give it a try. It worked for me after two days of trying to restore a phone in recovery mode.

Step 1. On your Mac, go to your “Applications” folder.

Step 2. Now navigate to the “Utilities” folder.

Step 3. Launch "Terminal".

Step 4. Type "sudo nano /etc/hosts" (without quotes) and hit return.

Step 5. Enter your password

Step 6. Use the down arrow key to find the “gs.apple.com” entries. Once the cursor is in front, make sure you comment out the line(s) by entering “#” in front of the text.

Step 7. Save the file by pressing CONTROL+O.

Step 8. Exit the nano editor by pressing CONTROL+X. I found ctrl X didn't exit for me, so Try "return' key after Control O to save and exit.

Step 9. Restore your iDevice.

Windows:

Step 1. Start –> Programs –> Accessories

Step 2. Run Notepad or WordPad

Step 3. Click “Open..” from File menu.

Step 4. Browse to Windows/System32/drivers/etc

Step 5. In "files of type:" select all documents

Step 6. Open "hosts"

Step 7. Delete all line that has "gs.apple.com" or something like that

Step 8. Hit Save

Step 9. Restore your device

这个答案有帮助吗?

按维修分数 4

评论:

Could this be the first ifixit date? Ohhhhhh I love happy endings! Xx

添加一条评论

If the trick from Majesty does not work for you or mayer's answer did not change anything but you found a lot of corrosion on your logic board, I'd go with that. Go ahead and clean with a high grade (preferably over 90%)isopropyl alcohol and a brush, just be careful not to knock off any components of the board. Also pay good attention to the connectors and ribbon cable. I have seen the ends of the cable literally green with oxidation. After that dry it well, yes you can use a hair dryer on the cold settings to expedite that process. Re-assemble and give it a try and see what you got. BTW if you already have it open do yourself a favor and replace the battery so you do not have to mess with it at a later time. Good Luck and let us know.

这个答案有帮助吗?

按维修分数 3
添加一条评论

Try a manual DFU reset.

这个答案有帮助吗?

按维修分数 2

评论:

But thats for ipod touch. Is it possible to do in a nano?

Been trying menu+action dozens of times but nothing changes. Allways the same error message.

iPod Nano 5 gen has a DFU mode - getting it there isn't the same as the touch - To enter DFU, plug in USB cable, hold Select+Menu until screen goes off, then press Select+Menu again. If iTunes is running, it will download WTF and then FIRMWARE file that launches Disk Mode, allowing firmware restore.

http://purpleskank.wikidot.com/ipod-nano...

It stays with the same error message. Opened and found a lot of corrosion... maybe its related.

Well this may not have been the best answer given Maj. but I don't think it was bad enough to get your down vote.

添加一条评论

I have the same problem too but on a 1st generation iPod touch

这个答案有帮助吗?

按维修分数 0

评论:

Have tried restoring using recovery and dfu

添加一条评论

添加你的答案

BOL 将永远感激不已
浏览统计数据:

过去的24小时: 1

过去的7天: 7

过去的30天: 15

总计 4,154