跳转到主内容

修复你的物品

维修的权力

配件 & 工具

The Discovery Series I was introduced into the United Kingdom in October 1989.

2 个问题 查看全部

97 disco Barely running After warming up

My 97 Land Rover discovery starts acting up once it warms up....such as, misfiring, backfiring, no power, can't go over 40mph down hill, barely goes 10mph up hill. After 40mph, when I push on gas pedal it does absolutely nothing. The same effect you'd have if You just weren't pushing it at all. Once it drops below 40mph the gas pedal registers again...... Any suggestions?

回答此问题 我也有这个问题

这是一个好问题吗?

得分 0

评论:

If you can get it scanned, do that first. See what codes are coming up. Also vacuum leaks will cause all kinds of problems. Check all your vacuum lines for splits, breaks or brittleness.

完成的

We put a scanner on it and it comes up with codes for o2 sensors, camshaft position sensor, random misfire, and then some others that say check service manual. About 10 codes altogether.

完成的

We did however find a vacuum leak but didn't help after fixing it. And thank you for your comment I'll take any advice I can get

完成的

@adeterding any chance you can post the codes on here?

完成的

Camshaft position sensor is an important one. Will cause what you describe. Could also be the reason for setting the random misfire codes. However as OT03 mentioned, would you mind posting all your codes so we can better help you diagnose your issues.

完成的

添加一条评论

任天堂 Switch 套装

快速恢复到游戏的状态

购买 Switch 套装

任天堂 Switch 套装

快速恢复到游戏的状态

购买 Switch 套装

1个回答

Sounds like one or both of your catalytic converters are plugged. Simple test, remove exhaust at the header, put on your ear plugs and fire it up. Once it's warm, if it's not doing it, it's definitely your cats.

Good luck!

这个答案有帮助吗?

得分 0
添加一条评论

添加你的答案

Amber Deterding 将永远感激不已
浏览统计数据:

过去的24小时: 0

过去的7天: 2

过去的30天: 6

总计 69