跳转到主内容

Model A1369, 1.6, 1.7, or 1.8 GHz Processor, 64, 128 or 256GB Flash Storage

321 个问题 查看全部

MacBook Air 11" (Mid 2011) 820-3024 Runs off charger but wont charge

Hi, iv got a MacBook Air 11" (Mid 2011) 820-3024 which will run fine on the charger, but when the charger is unplugged it turns off.

Iv tried 2x different chargers and 2x different dc in boards and it still wont charge. The battery has been changed and when it had charge in it the mac would run fine off the battery alone, until it went flat, then wont charge again.

The mac reports that the battery is at 0% and to replace it now, even though it has been replaced twice already with the same result.

I have replaced ISL6259 also and still have the same problem.

Im testing PPDCIN_S5_CHGR on Q7080 and am getting 14.5 volts but it should be 18.5v according to the schematic.

The board has had some water damage at one point, but this seems to be only on the dc in board, the rest of the motherboard appears to be fine.

If I measure resistance to ground on that line I get 040.0kohm , but without another board to compare to that is meaningless.

All we know what is happening so far is the voltage isnt what it should be on that line, so il see if I can find any filters or something on that line.

Iv tried two charger and two dc in boards and get that same 14.5-14.8volts at the dc in board connector.

Here are some voltages from around ISL6250 :

CHGR_CSI_P

14.50v

CHGR_CSI_N

14.45v

CHGR_BOOT

12.89v

CHGR_UGATE

10.95

PP5V1_CHGR_VDDP

5.05v

CHGR_CSO_N

8.36v

CHGR_CSO_P

8.36v

SMC_BC_ACOK

2.97v

CHGR_RST_L

3.3v

CHGR_VNEG_R

1.3v

CHGR_VCOMP_R

1.3v

CHGR_DCIN

14.2v

CHGR_ACIN

3.74v

CHGR_ICOMP

1.54v

CHGR_CELL

0v

CHGR_VCOMP

1.52v

CHGR_VCOMP_R

1.44v

PP3V42_G3H

3.39v

tested :

R5420 = good

R7085 = 0.469M

R7080 = good

R7081 = good

R7005 = good

Voltage @ R7005 = 14.1v & 14.35v

Voltage @ R7080 = 14.69v & 5.57v

Voltage @ R7001 = 5.1v & 5.05v

Voltage @ R7085 = 14.62v & 5.7v

Voltage @ R5420 = 0.061v & 0.061v

回答此问题 我也有这个问题

这是一个好问题吗?

按维修分数 0
添加一条评论

1个答案

Fixed it !, was a combination of a water damaged dc in board, bad ISL6259 and once I got green light back, bad battery too.

这个答案有帮助吗?

按维修分数 0
添加一条评论

添加你的答案

crea 将永远感激不已
浏览统计数据:

过去的24小时: 0

过去的7天: 0

过去的30天: 4

总计 171