跳转到主内容

奥林巴斯数码相机的维修指南和支持。

185 个问题 查看全部

camera won't turn off while battery is insterted

My camera has decided that it will not turn off as long as I have the battery inserted. This started about 1.5 weeks ago (no dropping or damage happened), and still continues. I have to remove the batter to ensure that it turns off and not to drain the battery. This is the OM-D Mark 5 II model, just 14 months old. 2 months past warrenty which is killing me.

已回答! View the answer 我也有这个问题

这是一个好问题吗?

按维修分数 3

评论:

I have had this issue as well, anyhow I had still warranty and it was repaired by Olympus service.

添加一条评论

Macbook 电池维修套装

起价 $69.99

Buy Now

Macbook 电池维修套装

起价 $69.99

Buy Now

2个回答

已选择的解决方案

Hi,

Some suggestions to try:

1. Try a power reset -

Remove the battery from the camera

Turn on the camera.

Press and hold the shutter button for a minute or so. (This is to discharge the internal, non user removable back up battery. This battery maintains the settings in your camera when you remove the main battery).

Release the button and switch off the camera.

Re insert the battery and switch on the camera.

Try turning it off and see if it works correctly.

If it does you may have to reset the date and time settings etc., as these will all have defaulted to a factory default setting. Allow the backup battery at least 24 hours to recharge (from the main battery) before removing the main battery again.

2. If that didn't work, have you got the latest firmware installed in the camera? It may be that the firmware has become corrupted. Even if you have the latest firmware version installed try installing it again (I don't know if the camera will allow this or whether it only permits updates) and see if this resolves the problem.

Here is a link to the firmware for your camera.

http://www.olympusamerica.com/cpg_sectio...

这个答案有帮助吗?

按维修分数 3

评论:

The power rest worked for me.

It worked for me too, and I didn't even lose the date. Thanks

添加一条评论

I had this happen to me, but none of the above worked. What did work was using a hairdryer on it. (cool setting)

I remembered I had been at a splash park a couple weeks prior and thought maybe some moisture had gotten in.

My fix:

I opened the side rubber flap and took off the PC flash cap.

5 minutes of blowing air (cool) around the switch and into the USB/HDMI ports did the trick.

A week later it did start to act up again, but another few minutes of hairdryer took care of it.

Me thinks that switch isn't as weatherproof as the rest of the camera.

这个答案有帮助吗?

按维修分数 2

评论:

I second this. Exact same issue, and surprisingly the hairdryer treatment on the switch and ports area (maybe headphone socket allows air to reach power switch contacts ?) fixes it, but only for a short time, a couple of days.

I have the same problem but the camera is never near moisture. I do live on the coast but it is rarely humid.

yup....hairdryer worked, camera was fine until I was caught out in a deluge...so much for it being weatherproof, bit sad really, was considering an upgrade to em1mk2 but now I'm not so sure !

添加一条评论

添加你的答案

michelle 将永远感激不已
浏览统计数据:

过去的24小时: 10

过去的7天: 66

过去的30天: 320

总计 6,279