跳转到主内容

Water kettle manufactured by Phillips.

2 个问题 查看全部

What were the symptoms?

What were the symptoms that made you conclude that the capacitors was the problem?

My kettle is acting very strange. Most of the time the light in the on/off button is on, but the kettle is not heating the water. Sometimes, if I leave the kettle in the base it suddenly starts boiling. Every now and then the temperature indicators starts blinking in random order. In all the kettle has become completely unreliable to the extent were I'm suspecting it is undergoing a transformation to a higher form of being ;) Could this also be the capacitors going crazy, or should I look in a different direction?

Regards Anders

Block Image

Block Image

Block Image

Block Image

Block Image

已回答! View the answer 我也有这个问题

这是一个好问题吗?

得分 0
添加一条评论

1个回答

已选择的解决方案

Anders,

It sounds like the temperature control is the problem. Try disassembling and looking for bad, burned, or leaking components by visual inspection. If there are any bad capacitor you might be able to find them by looking for leaks. Otherwise, i would suspect the entire temperature control circuit. It's possible the sensor itself failed. These are usually a simple thermistor and easy to replace. Not sure about your model, but if you post some pictures maybe we can help better.

Best of luck

这个答案有帮助吗?

得分 3

评论:

Hi Daryl

Thank you for answering.

I have dismantled the kettle which is a Philips model HD4685/90/A equal to the one you find here: http://tinyurl.com/zsa8mto

I took some pictures of the circuit board. You can find them here: http://tinyurl.com/j797m92

There doesn't seem to be any leaks or burns regarding the components on the front of the circuit board. The chip on the back have some white stuff on it. I'm not sure what it is, but it does not seem to come from the inside of the chip?!

The white rubber pads came out when I dismantled the part of the kettle with the buttons. I'm not sure were they belong.

Where should I be looking for the temperature sensor?

Thanks in advance :)

完成的

Anders,

Have you replaced those capacitor already? If not i wouldn't hesitate to give that try.

To find the sensors: one of those sets of wire should lead out to some small button sized sensor mounted near or on the heating element.

The heavy gauge wires are power in and back out off the mains relay.

There are two gray sets of wires and two white.

From the step 6 picture of the guide it looks like a pair of grey wires run to the handle for the power button.

完成的

添加一条评论

添加你的答案

Anders Dahl 将永远感激不已
浏览统计数据:

过去的24小时: 0

过去的7天: 0

过去的30天: 3

总计 499