Repair guides for various Nikon camera accessories.

17 个问题 查看全部

Nikon MH-23 quick charger doesn't work.


I have a Nikon MH-23 quick charger. Some months ago, it suddenly stop charging the battery. Even the LED indicator doesn't turn on. I checked the fuse and it's ok. The voltage after the diode bridge is correct. The control IC also has voltage to feed it (5Vdc). In the output of the the flyback secondary side the voltage is also present (8Vdc). I tested the LED individually and it's fine, in fact I notice that the control IC don't send voltage to it.

Apparently neither component looks like broken or burned. Ofcourse, I know it doesn't assure the correct operation of each component. I believe maybe some protection is already activated. Some one have an idea of what's happening or how I must proceed to check it?.


已回答! View the answer 我也有这个问题


按维修分数 0

所有超过US$100.00或包含 Pro Tech工具包的订单免费送货!



与 #ImAGenius 分享您的维修故事


与 #ImAGenius 分享您的维修故事




Check to see if any of the capacitors have 'bulging' ends. Faulty capacitor(s) can produce incorrect voltages and may prevent the correct operation of the IC. See image for an example of what to look for.

Block Image


按维修分数 3


Ok, I'll check them. Thanks.


I was having the same problem and I found advice from a flickr site from eight years ago, as I am not as technically proficient as you seem to be and my battery is now charging. So I cannot take credit for this answer, but it was useful for me:

I've had this happen on my D40X a few times with the original battery. When the battery gets very low, the charger may fail to recognize the battery is present.

I don't know why, but this method worked for me multiple times:

Unplug the charger and remove the battery. Wait a few seconds. Plug in the charger without the battery. Wait a few seconds. Slide the battery in and out of the charger a few times and watch for the charge light to come on. If it comes on, leave the battery there for the whole cycle and you're OK again.

They key learning is to not let he battery get completely depleted before recharging. That is, to where the camera will shut itself down.


按维修分数 2


Great!, I'll try it.

Thanks for the info!

Thanks for your tip. I had a similar problem and did exactly as you advised above and now its working.


Did you manage to solve your Problem?

I have the same issue with my charger and my capacitors don't look like those in the picture.


按维修分数 1


I didn't solved yet, the capacitors in my charger also don't look like those in the picture. Maybe I need to measure the ESR of the capacitors to discard such possibility (fault capacitors), however I don't have an ESR meter. Other option is replace the electrolitic capacitors by new ones with the same specs and see if the charger have a different behaviour. If the electrolitic capacitors are not the issue, a deeper analysis of the charger will be needed. I mean, see the waveforms of the charger in the oscilloscope. If you can fix the issue please let me know.


I just soldered supply to the secondary site via USB 5V Charger and then it does it's work. The 5V goes behind D4 and ground to - at the wire spring for the battery. So the fault must be at the primary supply site. But until now I didn't finde enough time to search for a faulty component.

Thanks for the info. Then I'll focus on primary side!. Actually I also didn't find enough time to search for a faulty component. However if I find a faulty one I'll let you know.

Now the LED is flashing like charging the battery but after 3 hours the battery was still empty. So there needs to be more research.

I see. Sounds like the charger doesn't provide enough energy (voltage or current) to charge the battery. Did you find something weird with the primary side?. The battery doesn't suffered a deep discharge previously?.




Gerardo Hernandez Molina 将永远感激不已

过去的24小时: 5

过去的7天: 30

过去的30天: 134

总计 2,847