跳转到主内容

Won't charge battery, magsafe stays green.

I run a small computer repair shop and have done hundreds of repairs in practically every version of every Apple computer but this one has me stumped. Customer came in and the computer laptop would power on and everything would work except the wifi and the fan was on full blast constantly. Very annoying.

I popped it open to find that the previous shop working on this computer LEFT THE HEATSINK OFF THE CHIPS! Since the computer still worked I powered it down, ordered the heatsink and installed it. When I got everything back together the magsafe no longer lights up for more than 2 seconds if at all. I removed the dc-inboard and gave it an alcohol bath and re-flowed the solder and now it lights up, but stays green and doesn't actually charge the battery. I'm completely bewildered and would appreciate any help or diagnostic steps!

回答此问题 我也有这个问题

这是一个好问题吗?

得分 1
添加一条评论

1个回答

最有帮助的答案

reflowed what? What does it say with a known good OEM 85w charger attached and battery connected? battery not charging, or an X on the battery?

这个答案有帮助吗?

得分 3

评论:

I reflowed the solder in the DC board. The laptop does not lower up so nothing shows on the screen at all.

完成的

Get a new dc in board, these things are five bucks. Try turning it on by shorting SMC_ONOFF_L to ground. What voltages do you get for PM_SLP_S4_L, PPBUS_G3H, PP3V42_G3H, PP5V_S5, PP5V_S3, and PPVRTC_G3H?

完成的

Hello @zzz. I unfortunately don't have a schematic. Any advice on where I'd be able to find one?

完成的

添加一条评论

添加你的答案

amer jarrah 将永远感激不已
浏览统计数据:

过去的24小时: 0

过去的7天: 0

过去的30天: 1

总计 329