The Kindle Touch (D01200) is 4th generation of Kindle e-readers produced by Amazon. There is Wi-Fi or Wi-Fi/3G capability, all uploads are done by USB cable. It has 4 GB of storage and two months of battery life.

21 个问题 查看全部

My power/lock-unlock button doesn't work

The button that power on and lock/unlock the device doesn't work. This can be fixed?

已回答! View the answer 我也有这个问题

这是一个好问题吗?

按维修分数 4
添加一条评论

GIVE TOOLS. FIX FOREVER.

GIVE TOOLS.

FIX FOREVER.

Spread the Fixmas cheer.

GIVE TOOLS. FIX FOREVER.

Spread the Fixmas cheer.

4个回答

已选择的解决方案

There seems to be an answer here....

http://www.powerbookmedic.com/manual.php...

looks like a de-assemble does the the trick.

这个答案有帮助吗?

按维修分数 3

评论:

I reset my Kindle 4 times, (full factory), and presto, the power button is now working... I was ready to take it apart...

I reset my Kindle 3 times, (full factory), and presto, the power button is now working... I was ready to take it apart... Thanks Steve!

Partial disassemble + tightening 2 black screws at the bottom (4:19 in the video) solved problem for me.

Neither resetting a bunch nor just tightening those screws worked for me, but I disassembled a bit more and my button starting working again.

添加一条评论

On the off chance anyone else still has one of these in 2018, I had this same problem with a non-working power button. I verified the Kindle worked fine by removing and replacing the battery (it rebooted as expected).

I then had to fully disassemble it to start playing around with the power button. I noticed it worked, but only if I squeezed on the right side (screen facing up) of the USB micro input. I tried screwing down as hard as I felt comfortable on the two screws either side of the home button. Still, the power button only worked intermittently. I deduced it needed more pressure for whatever contact is between the switch and motherboard. So, I added the nearest spacer I could find: I peeled off one of the rubber pads from the inside of the back cover, cut it in half, then placed both halves just below the screw on the right side. I reassembled everything and voila, this old clunky e-reader is still chugging along.

I didn't investigate the actual cause of the problem since I was too lazy to remove the motherboard. But I'm okay with a little mystery.

这个答案有帮助吗?

按维修分数 1

评论:

In my case squeezing or pushing on the bezel above the power button did make the power button responsive. So solving the problem is definitely about some pressure/tightening in the area of the button.

Thanks to all of you for this great device saving hint!

添加一条评论

My kindle touch has the same problem now.

Going to deassemble it to try....

Although my new kindle paperwhite is on its way....

这个答案有帮助吗?

按维修分数 0
添加一条评论

you should buy a new one is only $60

这个答案有帮助吗?

按维修分数 -3

评论:

I think the name of the website is ifixit... emmm... i... fixit? With all respect of course.

添加一条评论

添加你的答案

Gonzalo Calandria 将永远感激不已
浏览统计数据:

过去的24小时: 15

过去的7天: 148

过去的30天: 784

总计 19,397