跳转到主内容

这款4.7英寸iPhone于2014年9月19日发布,是iPhone 6 Plus的缩小版。

5058 个问题 查看全部

Very weak wifi signal after housing replacement

I replaced the housing on a bent Iphone 6. I also changed the screen because it was cracked, the phone works perfectly except for the wifi antenna which is very weak and only has full bars if less than a meter away from the router. If you leave the room it will completely disconnect because it is that weak

I have a business of doing repairs for the past 4 years and I know what I am doing generally but this one has got me stuck..tried resetting network settings and all that, I think it is a physical problem. Any ideas? What to replace or checkup on?

It's just an iPhone 6 not a 6 plus.

已回答! 显示答案 我也有这个问题

这是一个好问题吗?

得分 10

评论:

change the battery of that phone, www.bewmont.com

完成的

添加一条评论

13个回答

已选择的解决方案

''I beleive you did not assemble the wifi antenna correctly. Theres a small jumper from wifi antenna to top frame that makes the top frame of the phone the antenna. If u did not assemble the jumper the wifi antenna become super weak.....Heres a pic of it.....http://www.ifanatix.hu/hun/service/iPhon...

IF THIS SMAL PIECE IS MISSING OR NOT INSTALLED PROPERLY YOU WILL HAVE NO WIFI ANTENNA.....THEREFORE SIGNAL WILL BE VERY WEAK!!!!!!

Its underneath the wifi antenna and MUST be installed properly.......Otherwise u have no antenna...... ''

Block Image

这个答案有帮助吗?

得分 8

评论:

Sam, I have the same problem as the other ones with an red housing. The middle hole in the frame is missing but I connected it on the left one whit the motherboard but no diffrence. So still the same problem, ordering wifi module now, contacts is connected, all screws are right.

Maybe try to scratch the contacts places for the screws? At the frame so they get contact. I will try this when I have the phone again

完成的

Excellent pic, detailed and factually correct.

完成的

Hi, I replaced the LCD of my iPhone 6 last week. After that my wifi connection is really slow and the range is strongly limited. I then replaced the wifi antenna and I am really convinced that I assembled it correctly (like shown on the pic). Is there any other thing I could try?

Thanks!

完成的

sam I replaced my housing and am having this same issue, I have tried to replace this little antenna however I dont completely have it fixed yet. Can we email I know I'm close to fixing this maybe theres something else I am missing. nballer32p@yahoo.com

完成的

@tomchai What does Main Antenna 2 (Part 2) do?

完成的

显示更多的7条评论

添加一条评论

Check all screws, screw holes, logic board holding brackets and antenna RF cable sockets on the top half of the phone.

这个答案有帮助吗?

得分 3

评论:

@tomchai what do you mean by logic board holding brackets and antenna RF cable sockets? Sorry for the newbie question but very frigging curious.

完成的

Those small washers and brackets that other people thought are just to hold the board in are actually doubled as RF conductors. Missing one may break the RF path so the phone loses that part of the antenna.

完成的

添加一条评论

I have fixed this problem today at the one I have replaced.

I removed the WiFi module and losed all screws in top, lose on the motherboard and remove simtray so I could bend it a little up.

Then took a knife and scratched all the threads of the screws in top then put it all back.

Went from finding my WiFi standing 2meters away, to finding all my neighbor's WiFi and full on almost all of them!

这个答案有帮助吗?

得分 2

评论:

any pictures?

完成的

All the marked threads in this photo made the trick for me. Also the top middle one that in the orginal photo is marked green wasn't even there in my housing but I made a bridge from the above middle one in the motherboard to the left top one

https://www.photobox.co.uk/my/photo/full...

完成的

link is dead :/

完成的

Works for me :/ send an email to me Alcohol96@live.se and

完成的

Hi Jonny , I have the same problem and I tried your link but it does not work. Could you please send it to my email : ps3recovery@hotmail.com, thanks

完成的

显示更多的10条评论

添加一条评论

Hi, it's possible that the new housing may be causing the issue, as they are probably not the same standard as the original.

You could try the logic board in a known working housing and see if that resolves it, if it does then it's the housing, if not, it may be logic board damage. :-)

这个答案有帮助吗?

得分 1

评论:

The housing is an original assembly with imei and the lot printed on the back so I hope it isn't the root of this issue..it looks so pretty and nice and brand new. Does anybody else have any more direct solutions?

I really appreciate your response!! Just seeing if there is a clearer or quicker check to do rather than taking apart the whole housing again

完成的

I don't think there is a quicker way, where did you purchase it from? Did the new housing come with all the parts pre assembled? It's possible you may have damaged the wifi antenna, try replacing it and see if it works again! :-)

完成的

添加一条评论

Hi I just figured out the problem. It's because of the abscence of the thin copper panel which is located under the wifi module. Basically when you or novices replace their phone's back plate, they might not think about the panel of which it magnifies the signal to the module. However, OEM companies dont offer the parts together. Maybe because of price, workforces or profits.. There are a few solutions.. 1. Take it to the repair shop. 2. This is my recommendation, and I also solved wifi problems through this. So, you need the original plate. At the Left upper corner, you can see the two black circle shape spongee. Underneath of it, there are copper plates which I've mentioned above. Just carefully take off with knife (you can easily take off from the plate.)

Then attach it to the new plate exactly same place!!! You can see the astonishing full wifi connection after assemble it. I hope this can help alot of people!! Sorry for my poor English! (Im a Korean :) ) Any question would be my pleasure XD

这个答案有帮助吗?

得分 1

评论:

Are you sure? The plate is part the Apple logo and is not easy to remove. There is no reference to it on any Apple or third party documentation, much less in relation to WI-FI enhancement.

完成的

This helped me !! :D Tnx man !

完成的

添加一条评论

I replaced both my iphone 6 and 6 plus with a green color back housing and both my wifi are very weak. I believe it is the aftermarket back housing bc prior to this replacement everything worked great. Don't sacrifice looks for functionality. Its not worth it. Changing mine back to oem once i have the time

这个答案有帮助吗?

得分 0
添加一条评论

Bennyb123 was the problem solved? if yes how?

这个答案有帮助吗?

得分 0

评论:

Ben kapon - I solved the problem by scratching some at all the places where the WiFi antenna is sreewed in to the housing. It was some color in the way or just bad connection so this worked good for me.

完成的

添加一条评论

Dudes you likely got the one small flex cable on the back of MB disconnected.There are 4 connections they make trick on you looking like connected but at least one of them is do not!Have a look into..

这个答案有帮助吗?

得分 0
添加一条评论

I have the solution to the fix. At the top left of your motherboard you see all those screw spot that kind of form into a circle. You need to make sure when you transfer those screws when you transfer your motherboard to the new housing, completely correct, and make sure your not losing any screws because if not all, most of those screws have to do with reception signal, like I always said, if it came with the screws then it was meant to be there, don't get lazy halfway through the fix. Good luck.

这个答案有帮助吗?

得分 0
添加一条评论

Check the wifi flex cable at the back of the mother board. This is either loose or needs replacement.

这个答案有帮助吗?

得分 0
添加一条评论

Thanks a lot for all your suggestion. It was very helpfull for me. My iPhone 6 is now working with full signal strength.

这个答案有帮助吗?

得分 0
添加一条评论

I changed my display earlier 3 days and wifi signal become very weak and drops. I went to repair shop and asked them for replacement. Tried many different dispaly all works good as I get full strength signal when the display is connect, but as soon as display is fited with screws the same issue happens. What to do?

这个答案有帮助吗?

得分 0

评论:

Check the wifi/Bluetooth antenna flex with 4 connections in top left under the motherboard. You need to remove the motherboard to flip it around and feel so they are pushed down correctly. When you connect a screen you push a little to get down the contacts for the screen and that may be enough just to get signal when the wifi/Bluetooth antenna hits the motherboard.

完成的

添加一条评论

This post is the first to show on google so i’ll post my issue with weak wifi after a housing replacement using non OEM. The signal was very weak despite only being a few meters away from the router, I checked all the jumpers and everything was ok, the wifi module looked good so I didn’t suspect this.

Just to be sure I removed the module to re-seat the connections and surprise surprise one of the connection plugs fell off, maybe damage during the removal of the motherboard. I placed a new one on and have full strength using a non oem housing.

Hope this helps

这个答案有帮助吗?

得分 0
添加一条评论

添加你的答案

bennyb123 将永远感激不已
浏览统计数据:

过去的24小时: 4

过去的7天: 14

过去的30天: 59

总计 41,340