跳转到主内容

东芝所制造的笔记本电脑。

1067 个问题 查看全部

Not working will not power up

I have the Toshiba C55t-A5218.

I couldnt get windows to come up, but later did.

However when the laptop was doing a restart, it died and now it wont power up at all (with adapter or battery.

Any suggestions? The power adapter is producing 19 volts. I have also completed an ohm test on the power adapter cable in the laptop, all is well there. It wont power up with the battery plugged in. But I am uncertain if the battery is charged.

Also removed the memory and still same results. Please help, or I have a boat anchor.

已回答! View the answer 我也有这个问题

这是一个好问题吗?

按维修分数 0

评论:

Toshiba offers a nice support page: SATELLITE C55T-A5218 SUPPORT

by

I tried another power adapter and it worked perfectly. So i ordered a new one and was even able to install WIN 10 on it and sold it to a person.

by

Hey thats GRAET !

The laptop is working aging :)

thank u Darren !

by

添加一条评论

Android 维修工具包

一个新的屏幕或电池就在一个套件之内。

现在开始购物

Android 维修工具包

一个新的屏幕或电池就在一个套件之内。

现在开始购物

4 Answers

已选择的解决方案

Darren, start by performing the following steps:

-Remove the battery and Power adapter

-Press and hold the power button for 30-45 seconds (with battery and power still removed)

-Insert just the battery and attempt to boot the laptop.

-Insert just the power adapter and attempt to boot the laptop.

If you have more than one memory module, remove one module and try booting with just one module installed.

The other thing I would try is to replace the power cord. Toshiba's are known to blink 5 times with a bad power cord.

这个答案有帮助吗?

按维修分数 2

评论:

I checked the power cord from outlet to adapter and from adapter to laptop. Produced 19 volts, would the cord still be bad or cause it to blink?

by

in theory no, in practice anything is possible.:)

by

Ok cool, will try it

by

5 blinks, bad battery.

by

I have to say thank you for this answer. Tried it and it worked first try. You are a life saver!

by

Show 2 more comments

添加一条评论
最有帮助的答案

Hard to tell here whats happening.

Try disconnecting the HD to see if that allow the system to startup (as far as it will without a HD).

这个答案有帮助吗?

按维修分数 2

评论:

HD removed and still same response. Plus when the battery is connected and i press the power button, the power light flashes 5 times and quits.If the power adapter is connected by itself no flashes and no activity.

by

添加一条评论

i have the same problem i think maybe CPU is gone, even tho its hardly used!

这个答案有帮助吗?

按维修分数 0

评论:

only starts with no ram

by

添加一条评论

I have no power at all. The laptop will not boot, nor does any indicator LED come on showing power is present. There is a good DC voltage at the power cord. The 3V battery cell is good, but I replaced it anyway in case I was only reading a surface charge. I disassembled the laptop and checked the main board fuse; it was good.

I have installed a new 10.8V main battery with no luck. I did remove the power cord and battery, held the power button down for 45 seconds, and then tried each of the power supplies; again with no luck. I suspect a bad power circuit on the motherboard. If that is true then the computer has turned into a brick.

这个答案有帮助吗?

按维修分数 0
添加一条评论

添加你的答案

Darren 将永远感激不已
浏览统计数据:

Past 24 Hours: 10

Past 7 Days: 65

Past 30 Days: 271

总计 37,442