2.26 or 2.4 GHz / White plastic unibody enclosure

678 个问题 查看全部

Keyboard and trackpad are not functioning

For some reason my macbook keyboard and trackpad are completely non-responsive. I know for a fact that the keyboard and trackpad are not the problem. Please don't fixate on replacing the keyboard and trackpad. I've tried replacing them multiple times with the same results.

Here are some other things I have tried:

1) External keyboard and mouse work perfectly fine. I can log into OS X and everything functions normally with an external keyboard and mouse.

2) I performed an SMC reset using the built in keyboard. As I said, I know the keyboard is good.

3) I can not reset the PRAM using the built in keyboard. I can reset the PRAM with the external keyboard.

The keyboard works before the chime (SMC reset) and does not work after the chime (can not reset PRAM). It seems like the logic board is turning off the keyboard when it chimes. Not sure what could cause this. Does anyone have any ideas?

已回答! View the answer 我也有这个问题

这是一个好问题吗?

按维修分数 0

评论:

Forgot to mention this... I also tried completely reinstalling OS X and still had the same problem. The problem existed in the OS X install DVD environment as well.

Also I forgot to mention, when I go into the settings and I click on the trackpad settings it tells me no trackpad found.

Tried booting into a Linux Mint live dvd and I am having the same issue.

I've tried top cases / keyboards that came from both 2009 and 2010 models. (This style of macbook was only made in 2009 and 2010).

添加一条评论

所有超过US$100或包含 Pro Tech工具包的订单免费送货!

浏览我们的商店

1个答案

已选择的解决方案

Both the internal keyboard & trackpad are connected into the same controller chip the external USB ports do. In fact they are USB devices!

So we need to look at this from a software side first.

OK, Can you run AHT on your system using the wired keyboard & mouse? Follow this Apple TN: Using Apple Hardware Test. See if it tells us any errors. The next thing I would try is starting up the system in safe mode. Follw this Apple TN: OS X - What is Safe Boot, Safe Mode?.

Let us know what you discover.

这个答案有帮助吗?

按维修分数 3

评论:

I just ran AHT and it said "No trouble found". I'm going to try an extended test and see if that returns anything different.

The extended test is also reporting "No trouble found.".

Safe mode didn't seem to solve anything either.

OK, Lets try a different tact here. What you'll need is to create a bootable external drive USB thumb drive or a HD (FireWire or USB). Then boot the system off your external drive. Did that make a difference?

I had the same problem in a Mavericks USB install environment. Also in a Snow Leopard install DVD too. I tried two different hard drives.

显示更多的13条评论

添加一条评论

添加你的答案

Chuck 将永远感激不已
浏览统计数据:

过去的24小时: 2

过去的7天: 14

过去的30天: 71

总计 6,148