MacBook Pro A1278 starts, apple logo appears then shuts down

My wife has a MacBook Pro a 1278 model that will not boot up or turn on. I'm not certain of the exact version of 1278 but the serial number is: W80226HJATM

When I press the power button I hear the fans start to spin, the screen lights up gray, the Apple logo appears, the progress bar on the The bottom blinks twice while the time dial spins one revolution then the screen goes black and the computer turns off.

I have searched through the forums to find anything that is applies as the system does not hang in eternity,blink on and off or sit spinning -- it starts the boot sequence then just crashes. It has worked mostly fine for a long while, nothing spilled that i am aware of, battery seems good and the problem exists whether it's plugged in or on battery.

I tried command S to diagnose as seen in another post but honestly don't know enough about macs to see what is out of the ordinary as it seems to be a standard boot log. At the end it prompts me to type exit to continue the boot Which I did and the following lines appeared:

KEXT loading now disabled

KEXT unloading now disabled

KEXT autounloading now disabled

Kernel requests now disabled

Can't Get KEXTD port

Syncing disks… Killing all processes



CPU halted

Airport: link down on space. Space reason 8 (disassociated because station leaving)


I managed to take a photo of the previous results I just typed above (before it shut down again) but not certain if there may have been more lines just before it died.

I've read some mention of resetting the smc but can't find any details how to do that.

we will go to our storage locker this afternoon to retrieve the boot disks but not certain what to look for or do when we try to boot off of them.

Thanks for any and all assistance.

Best regards,


已回答! 显示答案 我也有这个问题


得分 7

Early 2010 MBP 13” (A1278) with similar “glitches.”

Problem: MBP is turned on without opening any programs but letting 4-7 minutes transpire, move the mouse via the track pad & “pinwheel” shows up and all programs stop responding. Can’t even use the normal shut down.

Happens whether you’re on battery power or a/c power supply.

Restart and retry, within the 4-7 minute programs stop responding and “pinwheel” comes up and nothing works.

I upgraded memory from 4GB to 8GB

Upgraded to a SSD hard drive, reformatted and Mac OS reinstalled

Changed Main Logic Board

Changed battery (original was 83 months old)

Reformatted and reinstalled several times with removal & full erasing & reformatting of the SSD drive

Thought it was the trackpad, started it without touching the track pad & keyboard & used an external mouse. I thought maybe solved… NOT Solved!

I’m about to retry original memory and reformatting of the SSD drive.

Any more suggestions?





You would do the command-s boot in order to force the boot volume's file system, and repair if necessary.

At the prompt (after all the text stops showing up) you type /sbin/fsck -fy (thats fsck single space dash fy) return Note that this may not be able to fix all problems in a single pass, so if it finds and fixes anything (it'll print "***** FILE SYSTEM WAS MODIFIED *****"), run it again, and keep running it until it comes back with something like "The volume Macintosh HD appears to be ok."

If this doesn't work, or you could try to run disk repair (command-D) boot to get to disk tools to check the volume, or repair the OS X system.

If this answer is acceptable please remember to return and mark it.


得分 9


Thank you for your reply,

I tried the code at the root directory prompt as you recommended and it generated the following response:

:/root# /sbin/fcsk -fy
** /dev/rdisk0s2
** root file system
Executing fsck_hfs (version diskdev_cmds-491.6~3).
** checking journaled HFS overflow file
** checking catalog file
invalid record count
(4, 3798)
** the volume untitled could not be verified completely.
/dev/rdisk0s2 (hfs) EXITED WITH SIGNAL 8

I ran it twice but with the same result.


Best regards,


PS. please note that the
is supposed to denote the actual line breaks as they appear on the screen but don't seem to be recognised as format code here.


The HD is corrupted/damaged. It can not repair itself- or Apple's lightweight disk tool can't sort out the problem. Sometimes a 3rd party app like DiskWarrior, DriveGenius or TechToolPr can repair them (and sometimes the damage is too great and the drive must be scrapped)


I've run this, and it shows no errors... so I reboot to reinstall osx from a usb and as soon as I choose the installer it shuts down... what other problem could there be?


Has the machine been liquid damaged? Could be a keyboard or network card issue if it has.


I have the same issue with the same model. I found out after upgrading/ replacing the Ram and HD Drive for a friend that liquid had entered from the underside where the rubber feet used to be at some time. I found if I hold the startup key for 5-10 seconds, the light on the front blinks rapidly and then it will start up either normally or in safe mode but runs painfully horribly slow. I thought for sure it was a failing HD drive as the symptoms were identical to many others I've repaired. But upon further close up inspection found several components and connectors that had turned green. I cleaned these with alcohol and looks like (guesstimate) PMU and / or graphics chip is not getting proper voltage. It was near impossible to run hardware tests with the hardware hobbled. Another tech friend suggested that the keyboard may have gotten wet and this could cause some of these symptoms as well. Rather than pull out my flux and heat gun to do board level repairs, I've decided to replace the logic board with a 2.66




I had a late 08 MBP 15 once that did the same thing. I noticed it would continue to boot and not shut down as long as a key was pressed on the keyboard constantly.

Actually it was more like a key had to be pressed every two seconds or so or the machine would shut off.

I replaced the keyboard and that resolved the problem.


得分 2


Thanks for the tip. We tried it but no dice.

Gonna keep searching.

Much appreciated however.




I had the same issue, and did as suggested here.

It comes back with the message

  • Reparing the volume.

GetCatalogueRecord: No matching catalog record found

FixBadExtent: Could not get catalog record for fileID 1076956

  • The volume Machintosh HD could not be repaired.

Any suggestions in this situation?

Thanks in advance!


得分 1

I just encountered the asme problem my MacBook pro was connected to hard drives to make some backups but then in the middle of opening the hard drives, it went off and when I turn on the grey screen with the logo comes up, a loading bar shows up, it tries to load for some time and then and the bar disappears and after ten seconds the screen goes black and the laptop off! I also need your help please?


得分 1


I have same exact problem with my macbook pro A1278

I turn on the screen with the apple logo comes up, a loading bar shows up, it tries to load for some time and then and the bar disappears and after ten seconds the screen goes black and the laptop turns off!



@ michal. I am having same problem with my macbook a1278 as it doesn't shut down if keys are being pressed. How can i change my keyboard of a laptop.i am out of options here please help me. Can you give me your email id for help.



得分 0


David Kunz 将永远感激不已

过去 24 小时: 0

过去 7 天: 3

过去 30 天: 30

总计 71,239