跳转到主内容

修复你的物品

维修的权力

配件 & 工具

Wifi stops working shortly after startup

The AirPort wifi on my MBP would only work for 1-2 minutes at start up and then lost connection completely. It's not able to detect any wireless networks at all once it fails and if I turn off the wifi I'm not able to turn it back on again. The only way to make it reconnect is completely reboot the Mac but then the same problem will recur again - connect for a couple of minutes and then just drop dead.

I'm running Mavericks and the wifi was working sweetly until I changed the SuperDrive to a 1TB HDD. Not sure if that's related but the screen hinge area where the wifi and bluetooth cards reside now runs very hot after the new drive is installed.

Update

I removed the HDD caddy mount n reinstalled the SuperDrive (which was faulty btw) and also restored Mavericks from Time Machine. The AirPort still doesn't work. I think it's now confirmed that either the card or the cable is gone. So I ended up using a USB wifi dongle as a stop gap. Wifi is a lot slower now using the USB dongle and the Mac still gets quite hot in the heatsink area.

Update

Hi, Fabio, did u mean this thick black tape on top of the connector?

Block Image

已回答! View the answer 我也有这个问题

这是一个好问题吗?

得分 0
添加一条评论

LCD iPhone 屏幕维修套装

预算选项,涵盖在我们的终身保修中。

购买套装

LCD iPhone 屏幕维修套装

削减维修成本,而不是质量。

购买套装

2个回答

已选择的解决方案

This model Macbook Pro really heats up a lot, especially running Mavericks.

I had a similar problem. Was solved with the relocation of black tape that is next to the cable connector wifi and camera. This comes out of the monitor and connect the logic board. If the tape is out of place, u can have a short circuit there. Try cleaning the connection with isopropyl alcohol.

这个答案有帮助吗?

得分 1

评论:

I mentioned the black tape below the connector. From the picture seems to be all right with the connection.

Have you ever reset Smc and PRAM? Try to restore the disk permissions too.

If none of these solve, it may be that you have a physical problem in wifi card, or Flat Cable.

完成的

添加一条评论

Yea - I think you're cooking your wifi card… I'd stop using that drive. If you must have that drive I'd pull the card and look for a Wifi/USB dongle.

If this answer is acceptable please remember to return and mark it.

这个答案有帮助吗?

得分 0

评论:

Hi, last night I've removed the 1TB harddrive from the caddy mount and replaced it with a new SSD instead and freshly installed Mavericks from scratch. Still the same results and still gets pretty hot in the heat sink area. So I guess it's out with the caddy mount and see if it returns to previous working condition.

完成的

Good plan… Do you recall the problems Tim the Toolman Taylor'd get into in his never ending quest for more power?

完成的

Hi Fabio, this is only a photo I got from iFixit website to confirm which black tape u mentioned. I'll open the baby up tonight and have a look at the state of my one.

Tried resetting PRAM numerous times. Most of the time this is the only way to get the thing started. Haven't tried to reset SMC tho. Will try that tonight.

完成的

添加一条评论

添加你的答案

Timothy Wong 将永远感激不已
浏览统计数据:

过去的24小时: 0

过去的7天: 0

过去的30天: 0

总计 630