跳转到主内容

An easy to use home Espresso machine created by Saeco and rebranded for Starbucks. This machine is excellent for every day espresso drinkers and has an excellent build and product life.

144 个问题 查看全部

On light is on. No Ready light. Pump not working

Machine was fine yesterday. Today when I turned it on, the ON light came on but it never showed ready for either steam or brewing.

If I turn the steam knob, no water or steam comes out

If I press the "brew" button, nothing happens.

Machine does not seem to be heating at all.

You help much appreciated.

已回答! View the answer 我也有这个问题

这是一个好问题吗?

按维修分数 0
添加一条评论

PC 笔记本电池

An easy fix for a big power boost.

现在开始购物

PC 笔记本电池

An easy fix for a big power boost.

现在开始购物

1个答案

已选择的解决方案

If the machine is not heating (does the top feel warm at all?) then it's likely that you've either tripped the fusible link (protects against overheating), one of your thermostats is faulty or your heating element has ruptured and failed. You can check all of these with a voltmeter, but you'll need to take the top of the machine off first. Make sure the machine is unplugged, then check for continuity across each of aforementioned parts; they should all be closed. If any of them are open, or have no continuity, then that's your faulty part.

这个答案有帮助吗?

按维修分数 1

评论:

Hi Henry. Just saw this. Will try to look at this in next few days. Don't have a voltmeter but may be able to borrow one. Not sure about the continuity but expect I may understand when I get the cover off and/or read through the step-by-step guides. Will let you knowl Thanks.

Hi Henry, Now I am really embarrassed. Some work was being done on my building and the outlet was not working. I had looked at the breakers and all appeared to be okay. What really threw me off was that the red "on light" was coming on. On closer inspection, I now see that it is actually just a highly reflective red paint.. when you press the button in, it just rotates inside from white to black. But really does look like it is lit! The only other thing on that outlet is a Cuisinart so I discovered the plug was not working when I tried to chop cranberries for Thanksgiving. Anyway, thank you so much for your response and I will refer to your answer if I ever have problems again (after first testing the outlet!!)

I am also having the same issue however i think i burnt out the pump and boiler. I was cleaning the water tube and did not insert it correctly so no water was ever flowing. When i recognized it was flowing the machine had been turned on for some time. i turned it off to let it cool down. and when i turned it back on, nothing happens. no heat, no clicks, just the green light. do you think i burnt out the pump and the boiler? and are those easily replaceable?

Hi Yvonne. If the thermal fuse on the boiler has tripped due to overheating then it would cut power to both the heating element and the pump. You'll need a multimeter to test it (check for continuity), and if it's bad just replace it and everything should be fine. If the fuse is good then I would see if the pump is getting voltage; if so, and it's not running, then it's definitely dead. You can also check the continuity on the heating element but if's getting voltage but not heating then it's most likely ruptured and will need to be replaced as well.

添加一条评论

添加你的答案

Margaret Neuer 将永远感激不已
浏览统计数据:

过去的24小时: 0

过去的7天: 2

过去的30天: 10

总计 443