跳转到主内容

修复你的物品

维修的权力

商店

2.26 or 2.4 GHz / White plastic unibody enclosure

765 个问题 查看全部

I replaced logicboard but the ethernet doesn't always work.

I bought a liquid damaged macbook (a1342 2009) and also from someone else a logic board. I succesfully replaced the logic board with the other one, and it booted again. I now type this from that Macbook.

However, I made sure to test everything, and my ethernet won't work. It always says "Cable Unplugged", also when plugged in. When I put the cable into my original macbook, it immediately connects ok, so the cable is fine.

I read this has to do with the logicboard, and I am afraid I need to return it to my seller. Is there anything I could have done wrong that made the ethernet fail? (I don't t know of anything that affects it?) What could I try to get it working?

I do run OSX 10.7, so the mac should be supported fully.

==Update==

I tried another network cable, and suddenly it did work. But after I wiggle a tiny bit with that cable the connection gets lost, and I need to plug out and plug in again. So still not really working as it should. On my original Macbook, this would not cause disconnection.

已回答! 显示答案 我也有这个问题

这是一个好问题吗?

得分 0
添加一条评论

1个回答

已选择的解决方案

Look in the port with a magnifying light to see if there is any debris or corrosion or the pins are bent out of alignment.

这个答案有帮助吗?

得分 2

评论:

Thanks, will do that. I found out that if you press real hard with the cable it reconnects again. Maybe the pins are to little bending back or so, and thus disconnect. Going to look with a good lamp tomorrow.

完成的

I checked it, removed dust, but I can see that the metal pins inside the port do not all spring back to top position. Some remain at 75% height. I tried to poke them up and down to see if I could remove more dust, but to no avail.

I checked my 2 other macbooks and they all had the pins fully sprong back. I guess it's an issue with this logic board.

I am contemplating cleaning it by submerging it in isopropyl or so, but since I possible need to return this board to my seller and I am not sure if it won't damage it, I think it's not really fixable.

完成的

Don't alter the contact wires inside the connector! they are designed this way.

完成的

As this is a replacement board I would return it. It sounds like you have a cold solder joint at the connector (bad board).

完成的

Well, if I check my other logic boards, there the pins do all sit in 100% top position, this one has 2 that don't. I doubt it's a solder joint issue. Any way, I will indeed return it. Seller told me that he normally doesn't test ethernet ports, and agreed to take it back.

完成的

显示更多的1条评论

添加一条评论

添加你的答案

Peterdk 将永远感激不已
浏览统计数据:

过去的24小时: 0

过去的7天: 0

过去的30天: 0

总计 242