跳转到主内容

The Game Boy released on April 21, 1989 in Japan, followed by North America on July 31, 1989, and lastly in Europe on September 28, 1990. It is characterized by a large grey casing and model number DMG-01.

43 个问题 查看全部

Power but no startup sequence

I recently dug out my old gameboy, but despite supplying power, I do not get the logo block or sound when turned on. the led is red, though that just proves the led works.

I've tried with and without a cartridge, and with an 6V AC Adaptor, as well as four AA batteries that are fully charged.

I've checked for leaked capacitors, or acid damage from leaking batteries, but it looks like i've been lucky and there is no visible damage.

I've measured the voltage on the contrast, and I get a range of about 0.05 to 10V on the pot.

I couldn't find a voltage differential on the audio pot however. should there be one there yet if a startup hasn't occurred?

回答此问题 我也有这个问题

这是一个好问题吗?

得分 0
添加一条评论

1个回答

最有帮助的答案

Steven Hodgson, could be a bit like looking for the proverbial needle in a haystack:-) I attached the power schematic for the GB and may be this will help you out. Check the caps on the DC-DC board. Hope this helps, good luck.

Block Image

这个答案有帮助吗?

得分 1

评论:

thanks for replying oldturkey03. using the schematic i've checked, and the power is coming out at roughly those values. i checked the oscillator this morning and still running 4.19 MHz too.

完成的

添加一条评论

添加你的答案

Steven Hodgson 将永远感激不已
浏览统计数据:

过去的24小时: 0

过去的7天: 0

过去的30天: 1

总计 287