跳转到主内容

修复你的物品

维修的权力

配件 & 工具

帮助

当前版本: M Norris ,

标题:

MagSafe power adaptor or other problem?

文本:

We've been having some intermittent issues with the MagSafe adaptor not showing any light. One of the outermost pins was stuck in, yet the OS still showed the battery was charging. I ordered a replacement from Amazon but, as the laptop was still getting power, I elected to continue using the existing adaptor despite it not showing a light.

After a little while I noticed a really acrid, burning-electrical-insulation-type smell, which seemed to be coming from the MagSafe connector itself. This seems to have become ever so slightly discoloured, so I put it down to a short in the connector itself, and discontinued using it.

Since then, the replacement (and I have to confess, 'compatible, not-made-by-apple') power adaptor has turned up but, after plugging it in, no light comes on on the plug, and the OS is reporting that it's not charging.

This would suggest an issue with the cheap replacement adaptor, but I have confirmed that the power is actually getting to the two sets of input pins. Therefore, this would suggest an issue with the fifth 'charge' pin - but I'm wondering if, by using the old power adaptor while the charge light wasn't working, it's somehow stuffed up a board inside?

The laptop is on its way out anyway (a previous apple refurb model: battery completely shot - lasts 2 minutes from full charge; optical drive dead) we don't want to be spending a lot on keeping it going. If it is an issue with the power board I will be tempted to put it on eBay as a spares or repair laptop.

Please can anyone shed any light on this?

设备:

MacBook Pro 15" Core 2 Duo Model A1211

状态:

open

已接受的回答:

90162

编辑: M Norris ,

标题:

MagSafe power adaptor or other problem?

文本:

We've been having some intermittent issues with the MagSafe adaptor not showing any light. One of the outermost pins was stuck in, yet the OS still showed the battery was charging. I ordered a replacement from Amazon but, as the laptop was still getting power, I elected to continue using the existing adaptor despite it not showing a light.

After a little while I noticed a really acrid, burning-electrical-insulation-type smell, which seemed to be coming from the MagSafe connector itself. This seems to have become ever so slightly discoloured, so I put it down to a short in the connector itself, and discontinued using it.

Since then, the replacement (and I have to confess, 'compatible, not-made-by-apple') power adaptor has turned up but, after plugging it in, no light comes on on the plug, and the OS is reporting that it's not charging.

This would suggest an issue with the cheap replacement adaptor, but I have confirmed that the power is actually getting to the two sets of input pins. Therefore, this would suggest an issue with the fifth 'charge' pin - but I'm wondering if, by using the old power adaptor while the charge light wasn't working, it's somehow stuffed up a board inside?

The laptop is on its way out anyway (a previous apple refurb model: battery completely shot - lasts 2 minutes from full charge; optical drive dead) we don't want to be spending a lot on keeping it going. If it is an issue with the power board I will be tempted to put it on eBay as a spares or repair laptop.

Please can anyone shed any light on this?

设备:

MacBook Pro 15" Core 2 Duo Model A1211

状态:

open

已接受的回答:

90162

编辑: M Norris ,

标题:

MagSafe power adaptor or other problem?

文本:

We've been having some intermittent issues with the MagSafe adaptor not showing any light. One of the outermost pins was stuck in, yet the OS still showed the battery was charging. I ordered a replacement from Amazon but, as the laptop was still getting power, I elected to continue using the existing adaptor despite it not showing a light.

After a little while I noticed a really acrid, burning-electrical-insulation-type smell, which seemed to be coming from the MagSafe connector itself. This seems to have become ever so slightly discoloured, so I put it down to a short in the connector itself, and discontinued using it.

Since then, the replacement (and I have to confess, 'compatible, not-made-by-apple') power adaptor has turned up but, after plugging it in, no light comes on on the plug, and the OS is reporting that it's not charging.

This would suggest an issue with the cheap replacement adaptor, but I have confirmed that the power is actually getting to the two sets of input pins. Therefore, this would suggest an issue with the fifth 'charge' pin - but I'm wondering if, by using the old power adaptor while the charge light wasn't working, it's somehow stuffed up a board inside?

The laptop is on its way out anyway (a previous apple refurb model: battery completely shot - lasts 2 minutes from full charge; optical drive dead) we don't want to be spending a lot on keeping it going. If it is an issue with the power board I will be tempted to put it on eBay as a spares or repair laptop.

Please can anyone shed any light on this?

设备:

MacBook Pro 15" Core 2 Duo Model A1211

状态:

open

已接受的回答:

90162

原帖由: M Norris ,

标题:

MagSafe power adaptor or other problem?

文本:

We've been having some intermittent issues with the MagSafe adaptor not showing any light. One of the outermost pins was stuck in, yet the OS still showed the battery was charging. I ordered a replacement from Amazon but, as the laptop was still getting power, I elected to continue using the existing adaptor despite it not showing a light.

After a little while I noticed a really acrid, burning-electrical-insulation-type smell, which seemed to be coming from the MagSafe connector itself. This seems to have become ever so slightly discoloured, so I put it down to a short in the connector itself, and discontinued using it.

Since then, the replacement (and I have to confess, 'compatible, not-made-by-apple') power adaptor has turned up but, after plugging it in, no light comes on on the plug, and the OS is reporting that it's not charging.

This would suggest an issue with the cheap replacement adaptor, but I have confirmed that the power is actually getting to the two sets of input pins. Therefore, this would suggest an issue with the fifth 'charge' pin - but I'm wondering if, by using the old power adaptor while the charge light wasn't working, it's somehow stuffed up a board inside?

The laptop is on its way out anyway (a previous apple refurb model: battery completely shot - lasts 2 minutes from full charge; optical drive dead) we don't want to be spending a lot on keeping it going. If it is an issue with the power board I will be tempted to put it on eBay as a spares or repair laptop.

Please can anyone shed any light on this?

设备:

MacBook Pro 15" Core 2 Duo Model A1211

状态:

open