跳转到主内容
帮助

原帖由: Matt Hall ,

文本:

'''I had a MacBook Pro 2.16GHz Core 2 Duo that was experiencing similar problems.  '''

1. The screen was physically broken.

2. It powered on but there was no chime, the sleep light would come on but the display remained black.  Nothing would get around this, even dismantling it and running it with no screen attached but connected to an external monitor, nor shorting the system reset, solder points on the motherboard.

So, I bought a replacement screen from http://www.laptopscreen.com/ it arrived in about a week, shipped to New Zealand.  I dismantled the MacBook Pro and installed the new screen.

After this I was still at problem 2.  It booted but the screen wasn't turning on nor was the machine progressing any further into a startup.

Following advice here I wrapped the Macbook Pro up in a blanket and left it for 30 minutes.  I unwrapped it and waited a minute and tried to power it on. This worked it chimed and booted.  The problem was I still couldn't restart or shutdown the machine as I'd have to repeat the heat up process everytime.  So I left it in sleep mode.  This became annoying as I wanted to use the laptop as a Lion test machine and rebooting often would be needed.

So, I tried dismantling the laptop and heating up the ATI video chip with a hair dryer for 10minutes as per many other guides and youtube clips.  This didn't seem to have any effect.  It now wouldn't turn on reliably after being heated up in the blanket and when it did I had graphic corruption on the screen.

At this point I was done with this laptop. So I decided as one last step I'd give the oven solder reflow method a go (as per many other guides for fixing solder reflow problems).  As I couldn't be sure what part was actually causing this issue I decided to bake the whole logic board.  I removed it from the machine, took all the stickers off, removed the emi foam pads on the ports, took of any kapton tape & plastic covers and put it in the oven at 200c for 9 minutes on balls of tin foil to keep it level.   I let it cool with the door open for 5-10 minutes then for another 15-20 on the bench.  I was concerned the ambient light sensor might melt as it looked plasticy but it didn't.  Some of the solder points looked nice and shiny after removing it form the oven so it was definitely hot enough for some re flowing to occur.

After putting everything back on the logic board and reassembling the laptop, I powered it on.  First go it chimed and booted to the Finder, so I tried a restart, that worked.  So I tried a Shut Down and power on that worked.  I tried a power on from battery 2 hours later, it worked.  I just powered it on now, 24 hours later and it's chimed and booted.  No graphic corruption either.

So anyone in a similar position I can recommend the oven method.  It might not work forever but mine now boots and is usable for now!

Regards,

Matt

状态:

open