跳转到主内容
帮助

当前版本: Blxthe ,

标题:

Display works for a couple of seconds on startup and then turns off

文本:

Hi there,
I was wondering if anyone would have the answer to my really strange situation.
Basically, every time I want to turn my MacBook on, I either have to disconnect the battery and then plug it back in and then it will boot up as normal, or I have to reset the SMC every single time and then it will turn on as normal.
When it turns on, the built-in display works for less than a minute and then randomly turns off and then will not turn on again until the machine is shut down and then powered on again.
if connected to my TV via HDMI cable, there is nothing wrong with the picture at all.
Also, when I press on the chassis around the keyboard, the display on my TV flickers and even randomly disconnects, I’m not sure if this is relevant or not, I just thought i should include it.
Also, when the MacBook powers on, it is fine for a bit but then must be plugged into power otherwise it will go to sleep. I don’t think this is a battery issue because I have tried two batteries and the problem still persists.
I’m fairly sure this may be a logic board issue, as I have bought a new display cable and the issue persists. I read somewhere that it may be an issue with a water damaged chip but everything seems to look fine on the board.
If someone could please point me in the right direction I will be forever grateful!
+
+
+
+UPDATE:
+
+This is a picture of coconut battery:
+
+[image|2452050] [image|2452051]
+
+
+
+When I hold D while starting up, it says “starting internet recovery” and then displays this error:
+
+[image|2452052]

设备:

MacBook Pro 15" Retina Display Mid 2012

状态:

open

原帖由: Blxthe ,

标题:

Display works for a couple of seconds on startup and then turns off

文本:

Hi there,

I was wondering if anyone would have the answer to my really strange situation.

Basically, every time I want to turn my MacBook on, I either have to disconnect the battery and then plug it back in and then it will boot up as normal, or I have to reset the SMC every single time and then it will turn on as normal.

When it turns on, the built-in display works for less than a minute and then randomly turns off and then will not turn on again until the machine is shut down and then powered on again.

if connected to my TV via HDMI cable, there is nothing wrong with the picture at all.

Also, when I press on the chassis around the keyboard, the display on my TV flickers and even randomly disconnects, I’m not sure if this is relevant or not, I just thought i should include it.

Also, when the MacBook powers on, it is fine for a bit but then must be plugged into power otherwise it will go to sleep. I don’t think this is a battery issue because I have tried two batteries and the problem still persists.

I’m fairly sure this may be a logic board issue, as I have bought a new display cable and the issue persists. I read somewhere that it may be an issue with a water damaged chip but everything seems to look fine on the board.

If someone could please point me in the right direction I will be forever grateful!

设备:

MacBook Pro 15" Retina Display Mid 2012

状态:

open