跳转到主内容
帮助

当前版本: timshimo ,

标题:

Apple Thunderbolt Display dead? In a pinch, reseat the boards.

文本:

This is not a question, but a suggested possible solution to a flickering/blacked-out Thunderbolt Display when you ''don’t'' have replacement parts in hand.
I was experiencing intermittent blackout/flickering/no-wake on my 27” Thunderbolt display (full symptoms below), and ordered an all-in-one replacement cable as a first step. I was doubtful, however, that it was simply a cable issue, so while the new cable was in the mail, I disconnected the display from power, then removed the logic board and power supply to see if there were any obvious visual clues of component failures on either board (thinking that I’d probably have to replace one or the other anyway). I saw nothing obviously burned or suspicious on the boards, and reassembled everything (I needed the MagSafe for charging), and upon plugging in the Thunderbolt to my Mac… what do you know? The display is revived!
The simple act of disconnecting and reconnecting each of the connectors on the logic board and power supply was effective at getting my display to work again. I’d only be guessing if I proposed theories as to ''why'' this was effective, but I suspect the key step was disconnecting the power supply from the logic board (and allowing the power supply to fully discharge). I’ve definitely encountered this sort of surprise fix with other things (as I’m sure anyone else who likes to fix things has experienced), but it’s definitely one of those long-shot attempts that actually ''does'' work on rare occasions.
To be clear, the process of unseating-and-reseating connectors ''isn’t'' really a fix, and I’ll have the replacement cable on hand if (when) the issue reoccurs, but I thought it would be helpful to remind people of this kind of solution when you’re in a pinch and can’t get/don’t have parts, and all other non-invasive stuff hasn’t worked.
Here were my symptoms:
* The display '''refused to wake up occasionally''', including both when it was already plugged into my Mac, or when I was reconnecting it (in cases where there had been no power outage)
* The display blackout occurred '''every time the display was disconnected from power''', or there was a power outage of any length. When the display was reconnected to power, the screen would refuse to turn on.
* Sound and camera were '''working normally''' in all cases
* Display '''was''' recognized in the computer’s hardware profile in all cases
* No faint image was seen when shining a secondary light source on the panel (i.e. it wasn’t a backlight issue)
* I experienced some flickering, but only on rare occasions
* Resetting SMC and NVRAM appeared to work when I first experienced the issue, but did not resolve the issue in this last event (I suspect these software resets only ''appeared'' to have an effect, when the issue was actually resolving for other reasons during the multiple restarts)
-
-*
+**UPDATE** I’ve isolated the problem to the power supply board. My display again refused to turn on after a power outage, and the solution was simply to disconnect-and-reconnect the power supply board from the logic board. The display then turned on with no hesitation. It’s still a hassle to go through the steps of removing the front glass, the 12 screws holding the LCD panel to the frame, and reseating one Molex (?) connection at the power supply side (not the connector on the logic board itself), but it’s way less hassle than disconnecting the whole LCD and all the logic board connections. It’s clear that the display needs a new power supply, so that’s next.

设备:

Apple Thunderbolt Display

状态:

open

已接受的回答:

660931

编辑: timshimo ,

标题:

Apple Thunderbolt Display dead? In a pinch, reseat the boards.

文本:

This is not a question, but a suggested possible solution to a flickering/blacked-out Thunderbolt Display when you ''don’t'' have replacement parts in hand.
I was experiencing intermittent blackout/flickering/no-wake on my 27” Thunderbolt display (full symptoms below), and ordered an all-in-one replacement cable as a first step. I was doubtful, however, that it was simply a cable issue, so while the new cable was in the mail, I disconnected the display from power, then removed the logic board and power supply to see if there were any obvious visual clues of component failures on either board (thinking that I’d probably have to replace one or the other anyway). I saw nothing obviously burned or suspicious on the boards, and reassembled everything (I needed the MagSafe for charging), and upon plugging in the Thunderbolt to my Mac… what do you know? The display is revived!
The simple act of disconnecting and reconnecting each of the connectors on the logic board and power supply was effective at getting my display to work again. I’d only be guessing if I proposed theories as to ''why'' this was effective, but I suspect the key step was disconnecting the power supply from the logic board (and allowing the power supply to fully discharge). I’ve definitely encountered this sort of surprise fix with other things (as I’m sure anyone else who likes to fix things has experienced), but it’s definitely one of those long-shot attempts that actually ''does'' work on rare occasions.
To be clear, the process of unseating-and-reseating connectors ''isn’t'' really a fix, and I’ll have the replacement cable on hand if (when) the issue reoccurs, but I thought it would be helpful to remind people of this kind of solution when you’re in a pinch and can’t get/don’t have parts, and all other non-invasive stuff hasn’t worked.
Here were my symptoms:
* The display '''refused to wake up occasionally''', including both when it was already plugged into my Mac, or when I was reconnecting it (in cases where there had been no power outage)
* The display blackout occurred '''every time the display was disconnected from power''', or there was a power outage of any length. When the display was reconnected to power, the screen would refuse to turn on.
* Sound and camera were '''working normally''' in all cases
* Display '''was''' recognized in the computer’s hardware profile in all cases
* No faint image was seen when shining a secondary light source on the panel (i.e. it wasn’t a backlight issue)
* I experienced some flickering, but only on rare occasions
* Resetting SMC and NVRAM appeared to work when I first experienced the issue, but did not resolve the issue in this last event (I suspect these software resets only ''appeared'' to have an effect, when the issue was actually resolving for other reasons during the multiple restarts)
+
*

设备:

Apple Thunderbolt Display

状态:

open

已接受的回答:

+660931

编辑: timshimo ,

标题:

Apple Thunderbolt Display dead? In a pinch, reseat the boards.

文本:

This is not a question, but a suggested possible solution to a flickering/blacked-out Thunderbolt Display when you ''don’t'' have replacement parts in hand.
I was experiencing intermittent blackout/flickering/no-wake on my 27” Thunderbolt display (full symptoms below), and ordered an all-in-one replacement cable as a first step. I was doubtful, however, that it was simply a cable issue, so while the new cable was in the mail, I disconnected the display from power, then removed the logic board and power supply to see if there were any obvious visual clues of component failures on either board (thinking that I’d probably have to replace one or the other anyway). I saw nothing obviously burned or suspicious on the boards, and reassembled everything (I needed the MagSafe for charging), and upon plugging in the Thunderbolt to my Mac… what do you know? The display is revived!
The simple act of disconnecting and reconnecting each of the connectors on the logic board and power supply was effective at getting my display to work again. I’d only be guessing if I proposed theories as to ''why'' this was effective, but I suspect the key step was disconnecting the power supply from the logic board (and allowing the power supply to fully discharge). I’ve definitely encountered this sort of surprise fix with other things (as I’m sure anyone else who likes to fix things has experienced), but it’s definitely one of those long-shot attempts that actually ''does'' work on rare occasions.
To be clear, the process of unseating-and-reseating connectors ''isn’t'' really a fix, and I’ll have the replacement cable on hand if (when) the issue reoccurs, but I thought it would be helpful to remind people of this kind of solution when you’re in a pinch and can’t get/don’t have parts, and all other non-invasive stuff hasn’t worked.
Here were my symptoms:
* The display '''refused to wake up occasionally''', including both when it was already plugged into my Mac, or when I was reconnecting it (in cases where there had been no power outage)
* The display blackout occurred '''every time the display was disconnected from power''', or there was a power outage of any length. When the display was reconnected to power, the screen would refuse to turn on.
* Sound and camera were '''working normally''' in all cases
* Display '''was''' recognized in the computer’s hardware profile in all cases
* No faint image was seen when shining a secondary light source on the panel (i.e. it wasn’t a backlight issue)
* I experienced some flickering, but only on rare occasions
* Resetting SMC and NVRAM appeared to work when I first experienced the issue, but did not resolve the issue in this last event (I suspect these software resets only ''appeared'' to have an effect, when the issue was actually resolving for other reasons during the multiple restarts)
-
-
-[small] Mods, please reclassify as needed.
+*

设备:

Apple Thunderbolt Display

状态:

open

编辑: timshimo ,

标题:

Apple Thunderbolt Display dead? In a pinch, reseat the boards.

文本:

-Not a question, but a suggested a possible solution to a flickering/blacked-out Thunderbolt Display when you ''don’t'' have replacement parts in hand.
+This is not a question, but a suggested possible solution to a flickering/blacked-out Thunderbolt Display when you ''don’t'' have replacement parts in hand.
I was experiencing intermittent blackout/flickering/no-wake on my 27” Thunderbolt display (full symptoms below), and ordered an all-in-one replacement cable as a first step. I was doubtful, however, that it was simply a cable issue, so while the new cable was in the mail, I disconnected the display from power, then removed the logic board and power supply to see if there were any obvious visual clues of component failures on either board (thinking that I’d probably have to replace one or the other anyway). I saw nothing obviously burned or suspicious on the boards, and reassembled everything (I needed the MagSafe for charging), and upon plugging in the Thunderbolt to my Mac… what do you know? The display is revived!
The simple act of disconnecting and reconnecting each of the connectors on the logic board and power supply was effective at getting my display to work again. I’d only be guessing if I proposed theories as to ''why'' this was effective, but I suspect the key step was disconnecting the power supply from the logic board (and allowing the power supply to fully discharge). I’ve definitely encountered this sort of surprise fix with other things (as I’m sure anyone else who likes to fix things has experienced), but it’s definitely one of those long-shot attempts that actually ''does'' work on rare occasions.
To be clear, the process of unseating-and-reseating connectors ''isn’t'' really a fix, and I’ll have the replacement cable on hand if (when) the issue reoccurs, but I thought it would be helpful to remind people of this kind of solution when you’re in a pinch and can’t get/don’t have parts, and all other non-invasive stuff hasn’t worked.
Here were my symptoms:
* The display '''refused to wake up occasionally''', including both when it was already plugged into my Mac, or when I was reconnecting it (in cases where there had been no power outage)
* The display blackout occurred '''every time the display was disconnected from power''', or there was a power outage of any length. When the display was reconnected to power, the screen would refuse to turn on.
* Sound and camera were '''working normally''' in all cases
* Display '''was''' recognized in the computer’s hardware profile in all cases
* No faint image was seen when shining a secondary light source on the panel (i.e. it wasn’t a backlight issue)
* I experienced some flickering, but only on rare occasions
* Resetting SMC and NVRAM appeared to work when I first experienced the issue, but did not resolve the issue in this last event (I suspect these software resets only ''appeared'' to have an effect, when the issue was actually resolving for other reasons during the multiple restarts)
+
+
+[small] Mods, please reclassify as needed.

设备:

Apple Thunderbolt Display

状态:

open

编辑: timshimo ,

标题:

Apple Thunderbolt Display dead? In a pinch, reseat the boards.

文本:

Not a question, but a suggested a possible solution to a flickering/blacked-out Thunderbolt Display when you ''don’t'' have replacement parts in hand.
I was experiencing intermittent blackout/flickering/no-wake on my 27” Thunderbolt display (full symptoms below), and ordered an all-in-one replacement cable as a first step. I was doubtful, however, that it was simply a cable issue, so while the new cable was in the mail, I disconnected the display from power, then removed the logic board and power supply to see if there were any obvious visual clues of component failures on either board (thinking that I’d probably have to replace one or the other anyway). I saw nothing obviously burned or suspicious on the boards, and reassembled everything (I needed the MagSafe for charging), and upon plugging in the Thunderbolt to my Mac… what do you know? The display is revived!
The simple act of disconnecting and reconnecting each of the connectors on the logic board and power supply was effective at getting my display to work again. I’d only be guessing if I proposed theories as to ''why'' this was effective, but I suspect the key step was disconnecting the power supply from the logic board (and allowing the power supply to fully discharge). I’ve definitely encountered this sort of surprise fix with other things (as I’m sure anyone else who likes to fix things has experienced), but it’s definitely one of those long-shot attempts that actually ''does'' work on rare occasions.
To be clear, the process of unseating-and-reseating connectors ''isn’t'' really a fix, and I’ll have the replacement cable on hand if (when) the issue reoccurs, but I thought it would be helpful to remind people of this kind of solution when you’re in a pinch and can’t get/don’t have parts, and all other non-invasive stuff hasn’t worked.
Here were my symptoms:
* The display '''refused to wake up occasionally''', including both when it was already plugged into my Mac, or when I was reconnecting it (in cases where there had been no power outage)
* The display blackout occurred '''every time the display was disconnected from power''', or there was a power outage of any length. When the display was reconnected to power, the screen would refuse to turn on.
* Sound and camera were '''working normally''' in all cases
* Display '''was''' recognized in the computer’s hardware profile in all cases
* No faint image was seen when shining a secondary light source on the panel (i.e. it wasn’t a backlight issue)
* I experienced some flickering, but only on rare occasions
* Resetting SMC and NVRAM appeared to work when I first experienced the issue, but did not resolve the issue in this last event (I suspect these software resets only ''appeared'' to have an effect, when the issue was actually resolving for other reasons during the multiple restarts)
-
-*

设备:

Apple Thunderbolt Display

状态:

open

原帖由: timshimo ,

标题:

Apple Thunderbolt Display dead? In a pinch, reseat the boards.

文本:

Not a question, but a suggested a possible solution to a flickering/blacked-out Thunderbolt Display when you ''don’t'' have replacement parts in hand.

I was experiencing intermittent blackout/flickering/no-wake on my 27” Thunderbolt display (full symptoms below), and ordered an all-in-one replacement cable as a first step. I was doubtful, however, that it was simply a cable issue, so while the new cable was in the mail, I disconnected the display from power, then removed the logic board and power supply to see if there were any obvious visual clues of component failures on either board (thinking that I’d probably have to replace one or the other anyway). I saw nothing obviously burned or suspicious on the boards, and reassembled everything (I needed the MagSafe for charging), and upon plugging in the Thunderbolt to my Mac… what do you know? The display is revived!

The simple act of disconnecting and reconnecting each of the connectors on the logic board and power supply was effective at getting my display to work again. I’d only be guessing if I proposed theories as to ''why'' this was effective, but I suspect the key step was disconnecting the power supply from the logic board (and allowing the power supply to fully discharge). I’ve definitely encountered this sort of surprise fix with other things (as I’m sure anyone else who likes to fix things has experienced), but it’s definitely one of those long-shot attempts that actually ''does'' work on rare occasions.

To be clear, the process of unseating-and-reseating connectors ''isn’t'' really a fix, and I’ll have the replacement cable on hand if (when) the issue reoccurs, but I thought it would be helpful to remind people of this kind of solution when you’re in a pinch and can’t get/don’t have parts, and all other non-invasive stuff hasn’t worked.

Here were my symptoms:

* The display '''refused to wake up occasionally''', including both when it was already plugged into my Mac, or when I was reconnecting it (in cases where there had been no power outage)
* The display blackout occurred '''every time the display was disconnected from power''', or there was a power outage of any length. When the display was reconnected to power, the screen would refuse to turn on.
* Sound and camera were '''working normally''' in all cases
* Display '''was''' recognized in the computer’s hardware profile in all cases
* No faint image was seen when shining a secondary light source on the panel (i.e. it wasn’t a backlight issue)
* I experienced some flickering, but only on rare occasions
* Resetting SMC and NVRAM appeared to work when I first experienced the issue, but did not resolve the issue in this last event (I suspect these software resets only ''appeared'' to have an effect, when the issue was actually resolving for other reasons during the multiple restarts)

*

设备:

Apple Thunderbolt Display

状态:

open