跳转到主内容
帮助

当前版本: Jay ,

标题:

Backlight issue.. External display-OK. Displays but NO Backlight!?

文本:

Hi,
I’m new in component level repair but been fixing iMacs for good 2 years now. Have a recent A1418 Apple IMAC 21.5'' Mid-2017 with Logic board 820-00597-06 EMC3069.
Have purchased it as spares: case with motherboard basically. Got the PSU for it. Powered it on. Got USB-C to DisplayPort cable tested display output - OK. Thought great! : ) I’m ready and good to go for expensive 4K Screen purchase from China! Month later I’m all set with nice NVME drive, 4K screen all ready assembled.. No display! Started checking issue.. When I’m on external screen all OK, everything works.
Shined with flashlight and can confirm that 4K screen actually is working and displaying but without backlight. This is a newer type Logic Board with 5 LEDs. I’m getting 4 solid LEDS and 5th is never ON. We’ve tried to plug in just a backlight cable from another damaged screen and NO backlight as well. eDP cable all fine displays the picture when you examine it with flashlight.
-Started checking possibility to get schematics. No luck for this board (820-00597-06 EMC3069). All I’ve found was 2015 NON-RETINA type boardview file. Area next to Backlight power connector looks very similar but I’m not good in determining/testing circuit board yet as not quite experienced in diagnosing/tracking the issue. All I can do and did is checked fuses with multimeter around that area - all seem fine.
+Started checking possibility to get schematics. No luck for this board (820-00597-06 EMC3069). All I’ve found was 2015 NON-RETINA type boardview file. Area next to Backlight power connector looks very similar but I’m not good in determining/testing circuit board yet as not quite experienced in diagnosing/tracing the issue. All I can do and did is checked fuses with multimeter around that area - all seem fine.
-I have some soldering skills, was doing LVDS connectors on 2009 iMacs and odd missing resistors if I visually can see something were missing. This is a next step for me with actual troubleshooting and I don’t know where to start.. Thought to ask here if maybe someone with experience could give me some hints what to try? I have a faulty logic board from 2012 iMac and could get some spare components from it, if something is identical obviously.
+I have some soldering skills, was doing LVDS connectors on 2009 iMacs and odd missing resistors if I visually can see something wrong. This is a next step for me with actual troubleshooting and I don’t know where to start.. Thought to ask here if maybe someone with experience could give me some hints what to try? I have a faulty logic board from 2012 iMac and could get some spare components from it, if something is identical obviously.
-Really really would appreciate ANY help. Hope there ere bright people who could teach/point me in right direction ; )
+Really really would appreciate ANY help. Hope there are bright people who could teach/point me in right direction ; )
Regards,
J
-[image|2067859][image|2067861][image|2067862][image|2067863]
+[image|2067859]
+
+[image|2067861]
+
+[image|2067862]
+
+[image|2067863]

设备:

iMac Intel 21.5" Retina 4K Display (2017)

状态:

open

编辑: Jay ,

标题:

Backlight issue.. External display-OK. Displays but NO Backlight!?

文本:

Hi,
I’m new in component level repair but been fixing iMacs for good 2 years now. Have a recent A1418 Apple IMAC 21.5'' Mid-2017 with Logic board 820-00597-06 EMC3069.
Have purchased it as spares: case with motherboard basically. Got the PSU for it. Powered it on. Got USB-C to DisplayPort cable tested display output - OK. Thought great! : ) I’m ready and good to go for expensive 4K Screen purchase from China! Month later I’m all set with nice NVME drive, 4K screen all ready assembled.. No display! Started checking issue.. When I’m on external screen all OK, everything works.
Shined with flashlight and can confirm that 4K screen actually is working and displaying but without backlight. This is a newer type Logic Board with 5 LEDs. I’m getting 4 solid LEDS and 5th is never ON. We’ve tried to plug in just a backlight cable from another damaged screen and NO backlight as well. eDP cable all fine displays the picture when you examine it with flashlight.
Started checking possibility to get schematics. No luck for this board (820-00597-06 EMC3069). All I’ve found was 2015 NON-RETINA type boardview file. Area next to Backlight power connector looks very similar but I’m not good in determining/testing circuit board yet as not quite experienced in diagnosing/tracking the issue. All I can do and did is checked fuses with multimeter around that area - all seem fine.
I have some soldering skills, was doing LVDS connectors on 2009 iMacs and odd missing resistors if I visually can see something were missing. This is a next step for me with actual troubleshooting and I don’t know where to start.. Thought to ask here if maybe someone with experience could give me some hints what to try? I have a faulty logic board from 2012 iMac and could get some spare components from it, if something is identical obviously.
Really really would appreciate ANY help. Hope there ere bright people who could teach/point me in right direction ; )
Regards,
J
+
+[image|2067859][image|2067861][image|2067862][image|2067863]

设备:

iMac Intel 21.5" Retina 4K Display (2017)

状态:

open

编辑: Kristen Gismondi (投票详情) ,

标题:

Backlight issue.. External display-OK. Displays but NO Backlight!?

文本:

Hi,

I’m new in component level repair but been fixing iMacs for good 2 years now. Have a recent A1418 Apple IMAC 21.5'' Mid-2017 with Logic board 820-00597-06 EMC3069.

Have purchased it as spares: case with motherboard basically. Got the PSU for it. Powered it on. Got USB-C to DisplayPort cable tested display output - OK. Thought great! : ) I’m ready and good to go for expensive 4K Screen purchase from China! Month later I’m all set with nice NVME drive, 4K screen all ready assembled.. No display! Started checking issue.. When I’m on external screen all OK, everything works.

Shined with flashlight and can confirm that 4K screen actually is working and displaying but without backlight. This is a newer type Logic Board with 5 LEDs. I’m getting 4 solid LEDS and 5th is never ON. We’ve tried to plug in just a backlight cable from another damaged screen and NO backlight as well. eDP cable all fine displays the picture when you examine it with flashlight.

Started checking possibility to get schematics. No luck for this board (820-00597-06 EMC3069). All I’ve found was 2015 NON-RETINA type boardview file. Area next to Backlight power connector looks very similar but I’m not good in determining/testing circuit board yet as not quite experienced in diagnosing/tracking the issue. All I can do and did  is checked fuses with multimeter around that area - all seem fine.

I have some soldering skills, was doing LVDS connectors on 2009 iMacs and odd missing resistors if I visually can see something were missing. This is a next step for me with actual troubleshooting and I don’t know where to start.. Thought to ask here if maybe someone with experience could give me some hints what to try? I have a faulty logic board from 2012 iMac and could get some spare components from it, if something is identical obviously.

Really really would appreciate ANY help. Hope there ere bright people who could teach/point me in right direction ; )

Regards,

J

设备:

iMac Intel 21.5" Retina 4K Display (2017)

状态:

-deleted
+open

编辑: Jay ,

标题:

Backlight issue.. External display-OK. Displays but NO Backlight!?

文本:

Hi,

I’m new in component level repair but been fixing iMacs for good 2 years now. Have a recent A1418 Apple IMAC 21.5'' Mid-2017 with Logic board 820-00597-06 EMC3069.

Have purchased it as spares: case with motherboard basically. Got the PSU for it. Powered it on. Got USB-C to DisplayPort cable tested display output - OK. Thought great! : ) I’m ready and good to go for expensive 4K Screen purchase from China! Month later I’m all set with nice NVME drive, 4K screen all ready assembled.. No display! Started checking issue.. When I’m on external screen all OK, everything works.

Shined with flashlight and can confirm that 4K screen actually is working and displaying but without backlight. This is a newer type Logic Board with 5 LEDs. I’m getting 4 solid LEDS and 5th is never ON. We’ve tried to plug in just a backlight cable from another damaged screen and NO backlight as well. eDP cable all fine displays the picture when you examine it with flashlight.

Started checking possibility to get schematics. No luck for this board (820-00597-06 EMC3069). All I’ve found was 2015 NON-RETINA type boardview file. Area next to Backlight power connector looks very similar but I’m not good in determining/testing circuit board yet as not quite experienced in diagnosing/tracking the issue. All I can do and did  is checked fuses with multimeter around that area - all seem fine.

I have some soldering skills, was doing LVDS connectors on 2009 iMacs and odd missing resistors if I visually can see something were missing. This is a next step for me with actual troubleshooting and I don’t know where to start.. Thought to ask here if maybe someone with experience could give me some hints what to try? I have a faulty logic board from 2012 iMac and could get some spare components from it, if something is identical obviously.

Really really would appreciate ANY help. Hope there ere bright people who could teach/point me in right direction ; )

Regards,

J

设备:

iMac Intel 21.5" Retina 4K Display (2017)

状态:

-open
+deleted

原帖由: Jay ,

标题:

Backlight issue.. External display-OK. Displays but NO Backlight!?

文本:

Hi,

I’m new in component level repair but been fixing iMacs for good 2 years now. Have a recent A1418 Apple IMAC 21.5'' Mid-2017 with Logic board 820-00597-06 EMC3069.

Have purchased it as spares: case with motherboard basically. Got the PSU for it. Powered it on. Got USB-C to DisplayPort cable tested display output - OK. Thought great! : ) I’m ready and good to go for expensive 4K Screen purchase from China! Month later I’m all set with nice NVME drive, 4K screen all ready assembled.. No display! Started checking issue.. When I’m on external screen all OK, everything works.

Shined with flashlight and can confirm that 4K screen actually is working and displaying but without backlight. This is a newer type Logic Board with 5 LEDs. I’m getting 4 solid LEDS and 5th is never ON. We’ve tried to plug in just a backlight cable from another damaged screen and NO backlight as well. eDP cable all fine displays the picture when you examine it with flashlight.

Started checking possibility to get schematics. No luck for this board (820-00597-06 EMC3069). All I’ve found was 2015 NON-RETINA type boardview file. Area next to Backlight power connector looks very similar but I’m not good in determining/testing circuit board yet as not quite experienced in diagnosing/tracking the issue. All I can do and did  is checked fuses with multimeter around that area - all seem fine.

I have some soldering skills, was doing LVDS connectors on 2009 iMacs and odd missing resistors if I visually can see something were missing. This is a next step for me with actual troubleshooting and I don’t know where to start.. Thought to ask here if maybe someone with experience could give me some hints what to try? I have a faulty logic board from 2012 iMac and could get some spare components from it, if something is identical obviously.

Really really would appreciate ANY help. Hope there ere bright people who could teach/point me in right direction ; )

Regards,

J

设备:

iMac Intel 21.5" Retina 4K Display (2017)

状态:

open