跳转到主内容
帮助

当前版本: DocM ,

标题:

MacBookPro only boots when an external screen is connected

文本:

My friends MacBook Pro 15" 2014 shows some pretty weird behavior.
 
When booting up the process suddenly stops and and a black bar appears on the upper part of the screen. Then nothing happens anymore.
 
I tried to find out if it was a graphics problem and connected it to a screen over the Thunderbolt port. It booted up normally and i can even disconnect the screen and work normally. It even works when i only have the VGA-Thunderbolt adapter connected without the screen. (For DViDVI and HDMI the cable/adapter isn’t tehreenough, there needs to be a screen attached, guess that’s a digital/analog thing)
I tried to find out if it was a graphics problem and connected it to a screen over the Thunderbolt port. It booted up normally and i can even disconnect the screen and work normally. It even works when i only have the VGA-Thunderbolt adapter connected without the screen. (For DViDVI and HDMI the cable/adapter isn’t tehreenough, there needs to be a screen attached, guess that’s a digital/analog thing)
 
He had NVIDIA CUDA installed and i removed all that because apparently that isn't supported in Mojave anyway. This didn't change anything though.
 
Does anyone know what might be going on here?
 
Thanks!

设备:

MacBook Pro 15" Retina Display Mid 2014

状态:

open

原帖由: DocM ,

标题:

MacBookPro only boots when an external screen is connected

文本:

My friends MacBook Pro 15" 2014 shows some pretty weird behavior.

When booting up the process suddenly stops and and a black bar  appears on the upper part of the screen. Then nothing happens anymore.

I tried to find out if it was a graphics problem and connected it to a  screen over the Thunderbolt port. It booted up normally and i can even  disconnect the screen and work normally. It even works when i only have the VGA-Thunderbolt adapter connected  without the screen. (For DVi and HDMI the cable/adapter isn’t tehre needs to be a screen attached, guess that’s a digital/analog thing)

He had NVIDIA CUDA installed and i removed all that because apparently that isn't supported in Mojave anyway. This didn't change anything though.

Does anyone know what might be going on here?

Thanks!

设备:

MacBook Pro 15" Retina Display Mid 2014

状态:

open