跳转到主内容

修复你的物品

维修的权力

配件 & 工具

帮助

当前版本: Wijnand ,

标题:

Battery not charging or seen by OS

文本:

Hi There,

Here's my problem,

The Macbook is functioning fine, but the battery shows a black cross. I can't boot without the power adapter connected but once started, even right in the beginning, i can disconnect the power and it boots up fine. The magsave connector is green.

Ive done the following step,

Reset the pram and smc even disconnected the pram cel for a wile.

Tested the battery and adapter on my other macbook (same model) And finally swapped both battery cable and mac connector with the working macbook. None solved the problem.

So i'm thinking its the logic board. and i would think this is reparable if i know witch component is the most common to fail.

Dos anyone have an suggestion?

Best regards,

Wijnand van der Linden

(i hope its readable english, is not my first language (dutch)

设备:

MacBook Core 2 Duo

状态:

open

已接受的回答:

49505

编辑: mayer ,

标题:

Battery not charging or seen by OS

文本:

Hi There,

Here's my problem,

The Macbook is functioning fine, but the battery shows a black cross. I can't boot without the power adapter connected but once started, even right in the beginning, i can disconnect the power and it boots up fine. The magsave connector is green.

Ive done the following step,

Reset the pram and smc even disconnected the pram cel for a wile.

Tested the battery and adapter on my other macbook (same model) And finally swapped both battery cable and mac connector with the working macbook. None solved the problem.

So i'm thinking its the logic board. and i would think this is reparable if i know witch component is the most common to fail.

Dos anyone have an suggestion?

Best regards,

Wijnand van der Linden

(i hope its readable english, is not my first language (dutch)

设备:

MacBook Core 2 Duo 2.16 GHZ
MacBook Core 2 Duo 2.16 GHZ

状态:

open

原帖由: Wijnand ,

标题:

Battery not charging or seen by OS

文本:

Hi There,

Here's my problem,

The Macbook is functioning fine, but the battery shows a black cross. I can't boot without the power adapter connected but once started, even right in the beginning, i can disconnect the power and it boots up fine. The magsave connector is green.

Ive done the following step,

Reset the pram and smc even disconnected the pram cel for a wile.

Tested the battery and adapter on my other macbook (same model) And finally swapped both battery cable and mac connector with the working macbook. None solved the problem.

So i'm thinking its the logic board. and i would think this is reparable if i know witch component is the most common to fail.

Dos anyone have an suggestion?

Best regards,

Wijnand van der Linden

(i hope its readable english, is not my first language (dutch)

设备:

MacBook Core 2 Duo 2.16 GHZ

状态:

open