跳转到主内容
帮助

当前版本: lukerockhill ,

标题:

issue after touch ic replacement. "curtains"

文本:

ive done numerous touch ic repairs but this is the 1st time im seeing this. yes, i ran the jumper to m1 then insulated it with uv solder mask, and used coins as heat sinks as to not reflow surrounding components. my issue is lines on the screen and cant see apple logo. 1st i tried reballing the meson ic from the phone. when i got the lines i assumed a bad chip and used a new one. still same issue. any ideas what i can check? i already went down the lcd fpc in diode mode with multimeter and compared to known good board. everything seems right. then i pulled meson and turned on the phone still doing the same thing with the chip removed. just looking for ideas as to what i can try next.
 
[image|1203468]
 
Edit: I got it working, turns out it was a strand of the tape that covers the touch ic area groundingpartially shorting one of the resistors (r2434/r2435)
Edit: I got it working, turns out it was a strand of the tape that covers the touch ic area groundingpartially shorting one of the resistors (r2434/r2435)
 
[image|1203646]

设备:

iPhone 6 Plus

状态:

open

已接受的回答:

431221

编辑: lukerockhill ,

标题:

issue after touch ic replacement. "curtains"

文本:

ive done numerous touch ic repairs but this is the 1st time im seeing this. yes, i ran the jumper to m1 then insulated it with uv solder mask, and used coins as heat sinks as to not reflow surrounding components. my issue is lines on the screen and cant see apple logo. 1st i tried reballing the meson ic from the phone. when i got the lines i assumed a bad chip and used a new one. still same issue. any ideas what i can check? i already went down the lcd fpc in diode mode with multimeter and compared to known good board. everything seems right. then i pulled meson and turned on the phone still doing the same thing with the chip removed. just looking for ideas as to what i can try next.
 
[image|1203468]

Edit: I got it working, turns out it was a strand of the tape that covers the touch ic area grounding one of the resistors (r2434/r2435)
[image|1203468]

Edit: I got it working, turns out it was a strand of the tape that covers the touch ic area grounding one of the resistors (r2434/r2435)
 
Edit: I got it working, turns out it was a strand of the tape that covers the touch ic area grounding a resistor.
[image|1203646]

设备:

iPhone 6 Plus

状态:

open

已接受的回答:

431221

编辑: lukerockhill ,

标题:

issue after touch ic replacement. "curtains"

文本:

ive done numerous touch ic repairs but this is the 1st time im seeing this. yes, i ran the jumper to m1 then insulated it with uv solder mask, and used coins as heat sinks as to not reflow surrounding components. my issue is lines on the screen and cant see apple logo. 1st i tried reballing the meson ic from the phone. when i got the lines i assumed a bad chip and used a new one. still same issue. any ideas what i can check? i already went down the lcd fpc in diode mode with multimeter and compared to known good board. everything seems right. then i pulled meson and turned on the phone still doing the same thing with the chip removed. just looking for ideas as to what i can try next.
 
[image|1203468]

Edit: I got it working, turns out it was a strand of the tape that covers the touch ic area grounding a resistor.
[image|1203646]
[image|1203468]

Edit: I got it working, turns out it was a strand of the tape that covers the touch ic area grounding a resistor.
[image|1203646]

设备:

iPhone 6 Plus

状态:

open

已接受的回答:

431221

编辑: lukerockhill ,

标题:

issue after touch ic replacement. "curtains"

文本:

ive done numerous touch ic repairs but this is the 1st time im seeing this. yes, i ran the jumper to m1 then insulated it with uv solder mask,  and used coins as heat sinks as to not reflow surrounding components.  my issue is lines on the screen and cant see apple logo. 1st i tried reballing the meson ic from the phone. when i got the lines i assumed a bad chip and used a new one. still same issue. any ideas what i can check? i already went down the lcd fpc in diode mode with multimeter and compared to known good board. everything seems right. then i pulled meson and turned on the phone still doing the same thing with the chip removed.  just looking for ideas as to what i can try next.

[image|1203468]

设备:

iPhone 6 Plus

状态:

open

已接受的回答:

431221

编辑: lukerockhill ,

标题:

issue after touch ic replacement. "curtains"

文本:

ive done numerous touch ic repairs but this is the 1st time im seeing this. yes, i ran the jumper to m1 then insulated it with uv solder mask, and used coins as heat sinks as to not reflow surrounding components. my issue is lines on the screen and cant see apple logo. 1st i tried reballing the meson ic from the phone. when i got the lines i assumed a bad chip and used a new one. still same issue. any ideas what i can check? i already went down the lcd fpc in diode mode with multimeter and compared to known good board. everything seems right. then i pulled meson and turned on the phone still doing the same thingthing with the chip removed. just looking for ideas as to what i can try next.
ive done numerous touch ic repairs but this is the 1st time im seeing this. yes, i ran the jumper to m1 then insulated it with uv solder mask, and used coins as heat sinks as to not reflow surrounding components. my issue is lines on the screen and cant see apple logo. 1st i tried reballing the meson ic from the phone. when i got the lines i assumed a bad chip and used a new one. still same issue. any ideas what i can check? i already went down the lcd fpc in diode mode with multimeter and compared to known good board. everything seems right. then i pulled meson and turned on the phone still doing the same thingthing with the chip removed. just looking for ideas as to what i can try next.
[image|1203468]

设备:

iPhone 6 Plus

状态:

open

编辑: lukerockhill ,

标题:

issue after touch ic replacement. "curtains"

文本:

ive done numerous touch ic repairs but this is the 1st time im seeing this. yes, i ran the jumper to m1 then insulated it with uv solder mask, and used coins as heat sinks as to not reflow surrounding components. my issue is lines on the screen and cant see apple logo. 1st i tried reballing the meson ic from the phone. when i got the lines i assumed a bad chip and used a new one. still same issue. any ideas what i can check? i already went down the lcd fpc in diode mode with multimeter and compared to known good board. everything seems right. then i pulled meson and turned on the phone still doing the same thing. just looking for ideas as to what i can try next.
[image|1203468]
ive done numerous touch ic repairs but this is the 1st time im seeing this. yes, i ran the jumper to m1 then insulated it with uv solder mask, and used coins as heat sinks as to not reflow surrounding components. my issue is lines on the screen and cant see apple logo. 1st i tried reballing the meson ic from the phone. when i got the lines i assumed a bad chip and used a new one. still same issue. any ideas what i can check? i already went down the lcd fpc in diode mode with multimeter and compared to known good board. everything seems right. then i pulled meson and turned on the phone still doing the same thing. just looking for ideas as to what i can try next.
[image|1203468]

设备:

iPhone 6 Plus

状态:

open

原帖由: lukerockhill ,

标题:

issue after touch ic replacement. "curtains"

文本:

ive done numerous touch ic repairs but this is the 1st time im seeing this. yes, i ran the jumper to m1 then insulated it with uv solder mask,  and used coins as heat sinks as to not reflow surrounding components.  my issue is lines on the screen and cant see apple logo. 1st i tried reballing the meson ic from the phone. when i got the lines i assumed a bad chip and used a new one. still same issue. any ideas what i can check? i already went down the lcd fpc in diode mode with multimeter and compared to known good board. everything seems right. then i pulled meson and turned on the phone still doing the same thing.  just looking for ideas as to what i can try next.

设备:

iPhone 6 Plus

状态:

open