跳转到主内容

Fix Your Stuff

Right to Repair

Parts & Tools

帮助

当前版本: oldturkey03 (投票详情) ,

标题:

Boot loop caused by possible hardware issue?

文本:

I have an iPhone 7 plus that a person gave to me to repair.  The person supplied their own screen (which I dont care for).  I noticed right off that someone tried to repair the phone, because when I opened it the touch and lcd flex were torn and the camera flex was stretched.  I replaced the screen and everything worked.  It worked all night and I left it charging.  The next morning it was still working just fine.  I rebooted it several times to triple check everything.  I always test calling, touch, camera etc.  When I was driving to drop it off, it randomly rebooted, then went black then back to the apple logo.  I tried to do a hard reset several times.  Nothing worked.  So, I tried to do an update and restore through itunes.  I was still in a boot loop.  So, then I started to work backwards.  I unplugged the camera flex and it booted fine, but the home button wasnt working.  When I plugged the camera flex back in, it boot loops.  I go home to swap the camera flex with a new one.  I get the same result.  If I leave the camera flex unplugged, it boots.  The home button at this point is non functional, so Im past that.  I just want to know if this sounds like a board level issue at this point?  Or maybe I should try another camera flex (I'd need to order one) to rule out having a bad original part and replacement part?

I know this was a lot of info.  I hope I explained everything clearly.

设备:

iPhone 7 Plus

状态:

openclosed
openclosed

原帖由: Brian Wood ,

标题:

Boot loop caused by possible hardware issue?

文本:

I have an iPhone 7 plus that a person gave to me to repair.  The person supplied their own screen (which I dont care for).  I noticed right off that someone tried to repair the phone, because when I opened it the touch and lcd flex were torn and the camera flex was stretched.  I replaced the screen and everything worked.  It worked all night and I left it charging.  The next morning it was still working just fine.  I rebooted it several times to triple check everything.  I always test calling, touch, camera etc.  When I was driving to drop it off, it randomly rebooted, then went black then back to the apple logo.  I tried to do a hard reset several times.  Nothing worked.  So, I tried to do an update and restore through itunes.  I was still in a boot loop.  So, then I started to work backwards.  I unplugged the camera flex and it booted fine, but the home button wasnt working.  When I plugged the camera flex back in, it boot loops.  I go home to swap the camera flex with a new one.  I get the same result.  If I leave the camera flex unplugged, it boots.  The home button at this point is non functional, so Im past that.  I just want to know if this sounds like a board level issue at this point?  Or maybe I should try another camera flex (I'd need to order one) to rule out having a bad original part and replacement part?

I know this was a lot of info.  I hope I explained everything clearly.

设备:

iPhone 7 Plus

状态:

open