跳转到主内容
帮助

当前版本: Nicholas Westmoreland ,

标题:

No power but PSU is fine

文本:

So I'm trying to fix my iMac 21.5" late 2012 (EMC2544/A1418)
 
There is no response from the power button, no fans, no screen light up, no beeps, nothing. So basically it won't turn on.
 
First off, none of the diagnostic LEDs light up.
 
* There is 12v measured on the logic board where the PSU plugs in.
* There is 3v measured on the logic board where the PSU plugs in.
* Coin cell voltage is 2.78v with computer unplugged.
* I have tried resetting the real time clock.
 
When I hold the power button in and plug the power in trying to force it to turn the fans on into high power mode, nothing happens.
 
Anyone have any ideas? Seems like a fault on the logic board, but I'm not going to buy a new one. I'm hoping there is something simple that I've overlooked.

设备:

iMac Intel 21.5" EMC 2544

状态:

open

已接受的回答:

418465

编辑: Dan ,

标题:

No power but PSU is fine

文本:

So I'm trying to fix my iMac 21.5 EMC2455/A141821.5" late 2012. There is no response from the power button, no fans, no screen light up, no beeps, nothing. So basically it won't turn on.2012 (EMC2544/A1418)
So I'm trying to fix my iMac 21.5 EMC2455/A141821.5" late 2012. There is no response from the power button, no fans, no screen light up, no beeps, nothing. So basically it won't turn on.2012 (EMC2544/A1418)
 
First off,There is no diagnostic LEDsresponse from the power button, no fans, no screen light upup, no beeps, nothing. So basically it won't turn on.
First off,There is no diagnostic LEDsresponse from the power button, no fans, no screen light upup, no beeps, nothing. So basically it won't turn on.
 
ThereFirst off, none of the diagnostic LEDs light up.
* There
is 12v measured on the logic board where the PSU plugs in.

There

* There
is 3v measured on the logic board where the PSU plugs in.

Coin

* Coin
cell voltage is 2.78v with computer unplugged.

I

* I
have tried resetting the real time clock.
ThereFirst off, none of the diagnostic LEDs light up.
* There
is 12v measured on the logic board where the PSU plugs in.

There

* There
is 3v measured on the logic board where the PSU plugs in.

Coin

* Coin
cell voltage is 2.78v with computer unplugged.

I

* I
have tried resetting the real time clock.
 
When I hold the power button in and plug the power in trying to force it to turn the fans on into high power mode, nothing happens.
 
Anyone have any ideas? Seems like a fault on the logic board, but I'm not going to buy a new one. I'm hoping there is something simple that I've overlooked.

设备:

iMac Intel 21.5" EMC 2455 late 20122544
iMac Intel 21.5" EMC 2455 late 20122544

状态:

open

原帖由: Nicholas Westmoreland ,

标题:

No power but PSU is fine

文本:

So I'm trying to fix my iMac 21.5 EMC2455/A1418 late 2012. There is no response from the power button, no fans, no screen light up, no beeps, nothing. So basically it won't turn on.

First off, no diagnostic LEDs light up.

There is 12v measured on the logic board where the PSU plugs in.

There is 3v measured on the logic board where the PSU plugs in.

Coin cell voltage is 2.78v with computer unplugged.

I have tried resetting the real time clock.

When I hold the power button in and plug the power in trying to force it to turn the fans on into high power mode, nothing happens.

Anyone have any ideas?  Seems like a fault on the logic board, but I'm not going to buy a new one. I'm hoping there is something simple that I've overlooked.

设备:

iMac 21.5" EMC 2455 late 2012

状态:

open