Skip to main content
Help

Current version by: oldturkey03 ,

Text:

@vonmonster the part number for the relay is 31800-21E20 and it is available at places [http://www.2wheelpros.com/oem-parts/suzuki-relay-starting-motor-31800-21e20-part.html?gclid=Cj0KCQjwwevLBRCGARIsAKnAJvewu0hHD-PuQfxbqsbrBcdjpAO3hU_wQGxZp4MTqn3gS0oD8qhFZ10aArs8EALw_wcB|like this.] Not sure about your trouble shooting and it does not look like that this particular relay is connected to the cooling fan. I would suggest that you check your water temperature sensorsensor, your cooling fan thermo switch and ensure that your fan works.
Here is the cooling system part of the service manual [document|3292]
@vonmonster the part number for the relay is 31800-21E20 and it is available at places [http://www.2wheelpros.com/oem-parts/suzuki-relay-starting-motor-31800-21e20-part.html?gclid=Cj0KCQjwwevLBRCGARIsAKnAJvewu0hHD-PuQfxbqsbrBcdjpAO3hU_wQGxZp4MTqn3gS0oD8qhFZ10aArs8EALw_wcB|like this.] Not sure about your trouble shooting and it does not look like that this particular relay is connected to the cooling fan. I would suggest that you check your water temperature sensorsensor, your cooling fan thermo switch and ensure that your fan works.
Here is the cooling system part of the service manual [document|3292]

Status:

open

Original post by: oldturkey03 ,

Text:

@vonmonster the part number for the relay is 31800-21E20 and it is available at places [http://www.2wheelpros.com/oem-parts/suzuki-relay-starting-motor-31800-21e20-part.html?gclid=Cj0KCQjwwevLBRCGARIsAKnAJvewu0hHD-PuQfxbqsbrBcdjpAO3hU_wQGxZp4MTqn3gS0oD8qhFZ10aArs8EALw_wcB|like this.] Not sure about your trouble shooting and it does not look like that this particular relay is connected to the cooling fan. I would suggest that you check your water temperature sensor and ensure that your fan works.

Status:

open