Skip to main content
Help

Original post by: Sheldon Semblante ,

Text:

hi there,

there is  few possible things could happen when you power wash your bike :

*the water liked in to its air cleaner and mixing with the fuel system .

* high tension wires got wet [interrupts the electrical flow to your spark plugs].

*  electrical system eq. computer box, egnition coil etc...

* water got through your tank.

*if sprayed on the pipe water it settling inside your exhaust system

with a little bit of water mixture on this places,engine sputters, back fires or sometimes it wont even start at all.

well to fix it try this procedures and test run it if you finish one.

1. make sure air filter is dry if not air dry it including its housing.

2.make sure your bike is completely turned off when you check your high tension wires going to the spark plug or you might get cranky (shocked).if wet air dry it including the plugs towards the spark plugs.

3. if you see a wet spot on some of your electrical system  air dry it.

4. check your fuel filter try draining fuel out of it and check if water did mix or not. if it did then you need to drain out fuel and feel it again with a new gas.

5. in this step most all bike owners love it just rev up and down until all water is out of your exhaust system.

6. if all steps have been made and still sputters you need a tune up( change spark plugs, clean injectors/carburetors , new air and fuel filters, oil change (suggestion not a must), valve setting and check engine timing. if you now how to do this or if not look for trusted service center.

hope you can hit the road sooner with a smooth run

thats all.

sheldon

Status:

open